1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

144hz through DP but not DVI dual link

Discussion in 'Monitors' started by Raven2311, 12 May 2018.

  1. Raven2311

    Associate

    Joined: 16 Oct 2012

    Posts: 3

    HI guys
    been racking my brain for a over a month now and ive finally come to ask for some direct help. i have a 1060 6gb and recently brought a Iiyama Gmaster GB2760QSU monitor to run games at 144mhz. i can get the 144mhz to work through the display port but, there is something wrong with the picture like some sort of screen resolution clash. ive got the setting in the nvidia settings on 2560x1440 and 144 mhz and then the same settings in game (native). the other weird thing is that i cant get the monitor to run at 144hz at all with a dvi dual link cable ive brought 3 trying to figure out if its the cable but it just doesn't appear as an option in the nvidia settings. can anyone think of something ive done wrong or not set properly. when i had a 24" 144hz monitor hooked up it was a beautiful picture and worked fine over the dvi dual link cable but this 27" just doesn't seem right.
    Thanks in advance
     
  2. Duff-Man

    Capodecina

    Joined: 24 Jun 2004

    Posts: 10,959

    Location: Nottingham

    I believe that DVI-D is only capable of ~60Hz at 2560*1440 (or 2560x1440)? It doesn't have the bandwidth for 120Hz+ at anything above 1080p.
     
  3. Raven2311

    Associate

    Joined: 16 Oct 2012

    Posts: 3

    hmmm thats a pain, mite try it though and see how it looks? thank u
     
  4. Raven2311

    Associate

    Joined: 16 Oct 2012

    Posts: 3

    swapped cables out and put the resolution down to 1920*1080 and still no option for 144hz with a dvi