1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Acer Laptop: Touchpad not working

Discussion in 'General Hardware' started by zeta101, 8 Mar 2006.

  1. zeta101

    Gangster

    Joined: 27 Aug 2004

    Posts: 134

    Hi guys, I've tried some googling and the OcUK search on this but it's stumped me!

    I went to sort out a friends laptop today (long story) and ended up using the Acer recover disks which reformat the HD and reinstall XP etc etc (it's an Acer Inspiron 5002 by the way). After the installation and windows was up and running, the touch/trackpad didn't work at all (including the buttons). A usb mouse worked fine though. I noticed in the task tray an icon for a "Synaptic" touch pad, opened it up and it was basically the settings panel/drivers for the pad. Everything looked fine, and it reported that it was enabled etc.

    Even so, I went to the synaptic website to download the drivers anyway (incidentally the site said to get them from the laptop manufacturer which I did). I reinstalled them and the problem still persists.

    Really strange because it's a fresh install of XP! Any ideas?

    Cheers
     
  2. leezer3

    Mobster

    Joined: 18 Jan 2006

    Posts: 2,955

    Location: Norwich

    Sounds like you've disabled the touchpad using a hotkey.
    Also check that there is no external mouse plugged in- The synaptics drivers will usually decide to disable the touchpad if there is one present.

    If this don't do anything, find a Linux LiveCD & boot with this- The synaptics touchpad drivers are built into all of the recent kernels & should allow you to find out if this is a hardware or Windows fault.

    -Leezer-
     
  3. zeta101

    Gangster

    Joined: 27 Aug 2004

    Posts: 134

    lol brilliant! I've just spoken to the friend on MSN and indeed fn+F7 solves the problem. I admit, it never occured to me that you could disable the touchpad via a hotkey!

    Thanks for the help leezer3 :D