1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Annoying Logon Logoff Loop (I don't think it's BlazeFind)

Discussion in 'Windows & Other Software' started by Tesla, 25 Jul 2006.

  1. Tesla

    Capodecina

    Joined: 19 Jan 2003

    Posts: 17,410

    Location: Bristol, UK

    In the process of cleaning up a customers laptop.

    I decided to not do a clean install, the reason it was running so slow was that the HDD was set to PIO mode.

    Anyway, I did an Adaware, Spybot and CCLeaner scan out of courtesy and also installed Norton on their request.

    I am now unable to logon to the laptop.

    As soon as I attempt a logon the laptop logs off reverting to the logon screen.

    This sounds exactly the same as the BlazeFind virus/adware but I do not think it is. I have followed the steps to remove BlazeFind by reinstalling the userinit.exe file via recovery console.

    I believe the problem lies within the Registry, the entry "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon
    Name: Userinit".

    However, as I am unable to logon it makes Registry editing rather akward.

    Any ideas or tips much appreciated,

    Chris
     
  2. bledd

    Don

    Joined: 21 Oct 2002

    Posts: 46,787

    Location: Parts Unknown

    have you tried it in safe mode?
     
  3. Tesla

    Capodecina

    Joined: 19 Jan 2003

    Posts: 17,410

    Location: Bristol, UK

    Yep, exactly the same problem.

    The OEM XP Home Ed. disc I use doesn't have the repair mode on for some reason either :confused:
     
  4. Duke

    Man of Honour

    Joined: 29 Jun 2003

    Posts: 33,725

    Location: Wiltshire

    You won't be able to do a repair if the laptop was loaded from a ghost image or similar, even if there is a sticker saying OEM etc it won't always recognise it being the same Windows version as a normal CD.

    Have you tried running a scan with a decent AV package like NOD32? Although you'd need to slave the HD into a desktop system.
     
  5. #Chri5#

    Soldato

    Joined: 27 Feb 2003

    Posts: 6,980

    Location: Shropshire

    I've seen this when winlogon.exe is missing from Windows\System32.
     
  6. Tesla

    Capodecina

    Joined: 19 Jan 2003

    Posts: 17,410

    Location: Bristol, UK

    I used a BartPE disc to fix the registry problem.

    However, the Virus has left other annoying quirks such as dodgy icons and system items with no names.

    Before doing a clean install (the user has loads of files all over the HDD so it would be a pain!) I would like to attempt a system restore. However, I am unable to start System Restore.

    Any ideas on this one please?
     
  7. bledd

    Don

    Joined: 21 Oct 2002

    Posts: 46,787

    Location: Parts Unknown