1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Apache 2.0.35 + PHP 5.8.0

Discussion in 'LOS Archive' started by Dj_Jestar, 25 Oct 2002.

  1. Dj_Jestar

    Caporegime

    Joined: 18 Oct 2002

    Posts: 28,817

    Location: Back in East London

    Hello.. this is infact my first post in the Linux forum :)

    I'm trying to run a PHP script on a Unix Web Server that's running Apache 2.0.35.

    I have changed the DirectoryIndex to look for index.php, but it will not run it.

    If I point my browser at the file it will open it and view the script, but it won't run it... has anyone got any ideas????

    thanks a lot!!!
     
  2. Shak

    PermaBanned

    Joined: 18 Oct 2002

    Posts: 2,010

    Location: Huddersfield / Antartica

    Taken from the Apache and PHP HOWTO written by me on this very forum

    Shak
     
  3. Dj_Jestar

    Caporegime

    Joined: 18 Oct 2002

    Posts: 28,817

    Location: Back in East London

    You sir, are an absolute DIAMOND! :D Thanks a helluvalot! :)

    Do you have a linkt to the full HOWTO by any chance? (Please don't tell me it's a sticky :rolleyes: ;))
     
  4. Shak

    PermaBanned

    Joined: 18 Oct 2002

    Posts: 2,010

    Location: Huddersfield / Antartica

  5. Dj_Jestar

    Caporegime

    Joined: 18 Oct 2002

    Posts: 28,817

    Location: Back in East London

  6. Shak

    PermaBanned

    Joined: 18 Oct 2002

    Posts: 2,010

    Location: Huddersfield / Antartica

    No problems mate, all my HOWTOs will be appearing on my site when Ive finished it then Ill make sure no-one misses them :p

    Shak
     
  7. Dj_Jestar

    Caporegime

    Joined: 18 Oct 2002

    Posts: 28,817

    Location: Back in East London

    Hello again, getting an error message after the make command on the PHP install...

    Code:
    make: fatal error: command failed for target 'sapi/cli/php'
    Also had a few lines 'Output line too long' before it :/

    Any ideas?

    I tried running make clean, but got the same message again on the second run :(
     
  8. Shak

    PermaBanned

    Joined: 18 Oct 2002

    Posts: 2,010

    Location: Huddersfield / Antartica

    Have you tried re-extracting the sources? Sounds like a dodgy set of sources to me, re-extract them, and if that doesnt work download a previous version. Is 5.8.0 testing? Im using 4.23 here, *I think*

    Shak
     
  9. Dj_Jestar

    Caporegime

    Joined: 18 Oct 2002

    Posts: 28,817

    Location: Back in East London

    I'm atually using PHP 4.3.0pre2.. my colleague thought that Pearl = PHP ;)

    Will try re-extracting :)
     
  10. Shak

    PermaBanned

    Joined: 18 Oct 2002

    Posts: 2,010

    Location: Huddersfield / Antartica

    Try the previous version, AFAIK the one that most people use is 4.23, sometimes there is a problem with the newer releases.

    Oh, and tell you collegue that PHP stands for

    People
    Hate
    Perl

    Shak
     
  11. Dj_Jestar

    Caporegime

    Joined: 18 Oct 2002

    Posts: 28,817

    Location: Back in East London

    Roger, Wilco! :D
     
  12. Shak

    PermaBanned

    Joined: 18 Oct 2002

    Posts: 2,010

    Location: Huddersfield / Antartica

    Did it work then?

    Shak
     
  13. Dj_Jestar

    Caporegime

    Joined: 18 Oct 2002

    Posts: 28,817

    Location: Back in East London

    Yup, I downgraded to 4.2.3 as it still failed after second doenload and extract... running make install now :D Ta once again! That's 2 drinks I owe ya ;)
     
  14. Shak

    PermaBanned

    Joined: 18 Oct 2002

    Posts: 2,010

    Location: Huddersfield / Antartica

    You can post them to me :p

    No problems sir, glad to see it worked :)

    Shak