1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ATI 10.03 not working on ubuntu 10.04

Discussion in 'Linux & Open Source' started by Robert1986, 15 Apr 2010.

  1. Robert1986

    Capodecina

    Joined: 17 Apr 2007

    Posts: 23,163

    Location: stat city

    I installed ubuntu 10.04 today then downloaded ati driver 10.03 for my 5850 gpu.

    I get error when rebooting after installing it.

    any idea how to fix it... and sorry for all the linux threads. :(
     
  2. Bhamid

    Gangster

    Joined: 16 Apr 2009

    Posts: 129

    Location: Maidstone, England

    ATI famously has awful driver support on Linux, was that from downloading it from the Administration->Hardware Drivers (thats what it is in 9.10 anyway) tab or from the ATI website?
     
  3. Robert1986

    Capodecina

    Joined: 17 Apr 2007

    Posts: 23,163

    Location: stat city

    ATI website. Hardware Driver update doesn;t work either, I get an error.
     
  4. Outcast

    Mobster

    Joined: 25 Jan 2008

    Posts: 2,921

    Location: Peterboro, Distro:Ubuntu

    Yup.. That sounds like ati !!
     
  5. Robert1986

    Capodecina

    Joined: 17 Apr 2007

    Posts: 23,163

    Location: stat city

    I am using ubuntu 10.04 and I am trying to install drivers through the hardware drivers in system > administration but I keep getting "SystemError: installArchives() failed" error.

    I also tried installing the latest drivers from the ati website but nothing worked.

    When I go to synaptic package manager it says "fglrx-amdcccle" broken. I tried to remove it but when I reboot, it says its still broken.

    Any help would be greatly appreciated as I hate using a low resolution on my desktop.
     
  6. Bhamid

    Gangster

    Joined: 16 Apr 2009

    Posts: 129

    Location: Maidstone, England

    Well, Lucid is in beta...
     
  7. Robert1986

    Capodecina

    Joined: 17 Apr 2007

    Posts: 23,163

    Location: stat city

    So, nothing should work? All I want is to install drivers for my 5850.
     
  8. Bhamid

    Gangster

    Joined: 16 Apr 2009

    Posts: 129

    Location: Maidstone, England

    No, I'm saying don't expect all of your hardware to work perfectly in a beta, especially hardware coming from a company notorius for providing poor driver support even on stable builds.