1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't Uninstall Explorer 7 - Help!

Discussion in 'Windows & Other Software' started by Abooie, 25 Mar 2006.

  1. Abooie

    Mobster

    Joined: 20 Apr 2004

    Posts: 4,587

    Location: Chepstow

    Here's my problem.

    I installed Explorer 7 beta on build 7.0.5296.0 on my PC. I had a few issues but nothing serious but then gave my PC to my parents and bought a lap top.

    They're on diap up and have had more issues with it then me (changing backgrounds / screen savers causing crashes - a known problem with this build) so I thought I'd uninstall it...

    No chance.

    If I try and uninstall via the control panel it asks me to log back in as the user that installed it. - Problem, this user has been deleted now.
    If I try running '%windir%\$NtUninstallie7bet2p$\spuninst\spuninst.exe' I get the same problem.
    MS have now changed the beta download build and if I try to reinstall with this as the new user it asks me to uninstall the old one first.
    I cannot (have spent quite a while now) find a download of build 7.0.5296.0 to reinstall as this user so I can take it off.

    Could do with some advice as I'm not in a position to reinstall Windows and all the associated gubbins.
     
  2. Scythe

    Soldato

    Joined: 23 Jun 2005

    Posts: 5,326

    You could try a repair installionation, wont get rid of anything just 'revert' it back to original system files, then go onto Windows Update and let it do its job.
     
  3. Matt-Page

    Mobster

    Joined: 23 Nov 2004

    Posts: 3,661

    I don't have it installed, nor have i even seen it yet, but i would imagine that User you deleted is stored somewhere for the application to remember.

    Try searching the registry for an entry of the username, in a IE7 key. (Start > Run > regedit > [Enter] DON'T delete things you need, or you will have problems)

    Failing that, could you not re-create that account and try to uninstall it?
     
  4. Abooie

    Mobster

    Joined: 20 Apr 2004

    Posts: 4,587

    Location: Chepstow

    Thanks,

    I've had a few searches for the key but I've not been able to track it down. I did try recreating the account (Same name) but it still didn't let me uninstall giving the same reason as above.
     
  5. Abooie

    Mobster

    Joined: 20 Apr 2004

    Posts: 4,587

    Location: Chepstow

    Figured out a solution.

    I removed

    [Prerequisite]
    condition = SingleOp,NoSort.UserMustBeSameAsInstall.Section

    From the uninstall spuninst.inf file so it didn't do the check.

    All works a treat now.