1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cisco 1921 + VDSL HWIC issue

Discussion in 'Networks & Internet Connectivity' started by Kei, 6 Apr 2019.

  1. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

    Having finally purchased myself the necessary HWIC (VA-DSL-A) I'm now having a hell of a time setting it up. I'm trying to get it to work on bt infinity 2.

    Looking at it,I don't think it's my config that's the issue, I think that it's firmware related. Having said that, I'm no expert in this so cannot be certain.

    This is the main bit of the config for running the interfaces:
    Code:
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/1
     ip address 192.168.0.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     ip tcp adjust-mss 1492
     duplex auto
     speed auto
     no mop enabled
    !
    interface Ethernet0/0/0
     no ip address
    !
    interface Ethernet0/0/0.101
     encapsulation dot1Q 101
     no ip address
     pppoe enable group global
     pppoe-client dial-pool-number 1
    !
    interface Dialer1
     ip address negotiated
     ip access-group 101 in
     no ip unreachables
     ip mtu 1492
     ip tcp adjust-mss 1452
     duplex auto
     speed auto
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     dialer pool 1
     ppp chap hostname bthomehub@btbroadband.com
     ppp chap password 7 1415060303092F23312A1337361115190205545856571A0D0C15
     ppp pap sent-username bthomehub@btbroadband.com password 7 0111120C54060307344E6E0B0D07051D0A08062B252066303A2F
    !
    ip forward-protocol nd
    !
    ip http server
    no ip http secure-server
    ip http client source-interface GigabitEthernet0/1
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static udp 192.168.0.3 9987 interface Dialer1 9987
    ip nat inside source static tcp 192.168.0.3 30033 interface Dialer1 30033
    ip nat inside source static tcp 192.168.0.3 10011 interface Dialer1 10011
    ip nat inside source static tcp 192.168.0.2 2564 interface Dialer1 2564
    ip nat inside source static tcp 192.168.0.2 2565 interface Dialer1 2565
    ip nat inside source static udp 192.168.0.2 2564 interface Dialer1 2564
    ip nat inside source static tcp 192.168.0.3 9988 interface Dialer1 9988
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 192.168.0.0 255.255.255.0 GigabitEthernet0/1
    !
    access-list 1 remark INTERNET-ACCESS
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 2 remark ONLY PERMIT TELNET FROM INTERNAL IPs
    access-list 2 permit 192.168.0.0 0.0.0.255
    access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
    access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 101 deny   ip 255.0.0.0 0.255.255.255 any
    access-list 101 deny   ip 248.0.0.0 7.255.255.255 any
    access-list 101 deny   ip host 0.0.0.0 any
    access-list 101 deny   ip host 255.255.255.255 any
    access-list 101 deny   tcp any any eq telnet
    access-list 101 deny   udp any any range 33400 34400
    access-list 101 permit icmp any any net-unreachable
    access-list 101 permit icmp any any host-unreachable
    access-list 101 permit icmp any any port-unreachable
    access-list 101 permit icmp any any packet-too-big
    access-list 101 permit icmp any any administratively-prohibited
    access-list 101 permit icmp any any source-quench
    access-list 101 permit icmp any any ttl-exceeded
    access-list 101 permit icmp any any echo-reply
    access-list 101 permit tcp any any established
    access-list 101 permit udp any any
    access-list 101 permit tcp any any eq 54021
    access-list 101 permit tcp any any eq 54022
    access-list 101 permit tcp any any eq 2564

    Currently I'm seeing this in the console shortly after bootup
    Code:
    VDSL_DAEMON-3-INITFAIL: VDSL Daemon Boot init retries done max times init failed.

    sh controller vdsl 0/0/0 gives the following output:
    Code:
    Controller VDSL 0/0/0 is DOWN
    
    Daemon Status:           Start
    
    DSL modem is not yet initialized.
    
    Firmware        Source          File Name (version)
    --------        ------          -------------------
    OS FW           embedded        VDSL_LINUX_DEV_01212008 (1)
    
    Training Log :  Stopped
    Training Log Filename : flash:vdsllog.bin
    

    sh flash gives:
    Code:
    1     68923232 Mar 3 2014 20:02:30 +00:00 c1900-universalk9-mz.SPA.152-4.M5.bin
    2         3064 Mar 3 2014 20:10:24 +00:00 cpconfig-19xx.cfg
    

    I've since added a firmware for the card (though it's pretty old)
    Code:
    1     68923232 Mar 3 2014 20:02:30 +00:00 c1900-universalk9-mz.SPA.152-4.M5.bin
    2         3064 Mar 3 2014 20:10:24 +00:00 cpconfig-19xx.cfg
    3      2602194 Apr 6 2019 15:15:08 +00:00 vdsl.bin-A2pv6C033c_d23e
    

    and then set it as follows:
    Code:
    controller VDSL 0/0/0
     operating mode auto
     firmware filename flash:/vdsl.bin-A2pv6C033c_d23e
    

    Having done all that, sh controller vdsl 0/0/0 still shows exactly the same as above. I've acquired an image for IOS 15.7 (c1900-universalk9-mz.SPA.157-3.M2.bin) and tried that along with a much later firmware for the card (va_a_39t_b_38r1_24o.bin) and it is still behaving as above.

    This is my original working config with the separate OR modem.
    Code:
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     no ip address
     ip tcp adjust-mss 1452
     duplex auto
     speed auto
     pppoe enable group global
     pppoe-client dial-pool-number 1
    !
    interface GigabitEthernet0/1
     ip address 192.168.0.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     ip tcp adjust-mss 1350
     duplex auto
     speed auto
     no mop enabled
    !
    interface Dialer1
     ip address negotiated
     ip access-group 101 in
     no ip unreachables
     ip mtu 1492
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     dialer pool 1
     ppp chap hostname bthomehub@btbroadband.com
     ppp chap password 7 1415060303092F23312A1337361115190205545856571A0D0C15
     ppp pap sent-username bthomehub@btbroadband.com password 7 0111120C54060307344E6E0B0D07051D0A08062B252066303A2F
    !
    ip forward-protocol nd
    !
    ip http server
    no ip http secure-server
    ip http client source-interface GigabitEthernet0/1
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static udp 192.168.0.3 9987 interface Dialer1 9987
    ip nat inside source static tcp 192.168.0.3 30033 interface Dialer1 30033
    ip nat inside source static tcp 192.168.0.3 10011 interface Dialer1 10011
    ip nat inside source static tcp 192.168.0.2 2564 interface Dialer1 2564
    ip nat inside source static tcp 192.168.0.2 2565 interface Dialer1 2565
    ip nat inside source static udp 192.168.0.2 2564 interface Dialer1 2564
    ip nat inside source static tcp 192.168.0.3 9988 interface Dialer1 9988
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 192.168.0.0 255.255.255.0 GigabitEthernet0/1
    !
    access-list 1 remark INTERNET-ACCESS
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 2 remark ONLY PERMIT TELNET FROM INTERNAL IPs
    access-list 2 permit 192.168.0.0 0.0.0.255
    access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
    access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 101 deny   ip 255.0.0.0 0.255.255.255 any
    access-list 101 deny   ip 248.0.0.0 7.255.255.255 any
    access-list 101 deny   ip host 0.0.0.0 any
    access-list 101 deny   ip host 255.255.255.255 any
    access-list 101 deny   tcp any any eq telnet
    access-list 101 deny   udp any any range 33400 34400
    access-list 101 permit icmp any any net-unreachable
    access-list 101 permit icmp any any host-unreachable
    access-list 101 permit icmp any any port-unreachable
    access-list 101 permit icmp any any packet-too-big
    access-list 101 permit icmp any any administratively-prohibited
    access-list 101 permit icmp any any source-quench
    access-list 101 permit icmp any any ttl-exceeded
    access-list 101 permit icmp any any echo-reply
    access-list 101 permit tcp any any established
    access-list 101 permit udp any any
    access-list 101 permit tcp any any eq 54021
    access-list 101 permit tcp any any eq 54022
    access-list 101 permit tcp any any eq 2564

    sh diag
    Code:
    Slot 0:
        C1921 Mother board 2GE, integrated VPN and 2W Port adapter, 3 ports
        Port adapter is analyzed
        Port adapter insertion time 01:22:28 ago
        EEPROM contents at hardware discovery:
        PCB Serial Number        : *********
        Hardware Revision        : 1.0
        Part Number              : 73-12850-09
        Top Assy. Part Number    : 800-33408-04
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 02
        Product (FRU) Number     : CISCO1921/K9
        Version Identifier       : V05
        CLEI Code                : CMMHF10ARA
        Processor type           : C8
        Chassis Serial Number    : **********
        Chassis MAC Address      : **********
        MAC Address block size   : 32
        Manufacturing Test Data  : 00 00 00 00 00 00 00 00
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF C1 8B 46 4F 43 31 37 35 31 34 47 58 45 40
          0x10: 06 AC 41 01 00 82 49 32 32 09 C0 46 03 20 00 82
          0x20: 80 04 42 41 30 88 00 00 00 00 02 02 CB 8C 43 49
          0x30: 53 43 4F 31 39 32 31 2F 4B 39 89 56 30 35 20 D9
          0x40: 04 40 C1 CB C2 C6 8A 43 4D 4D 48 46 31 30 41 52
          0x50: 41 09 C8 C2 8B 46 43 5A 31 38 31 30 43 30 56 32
          0x60: C3 06 A8 0C 0D C2 A5 C0 43 00 20 C4 08 00 00 00
          0x70: 00 00 00 00 00 F3 00 51 40 00 8B 41 00 3C 42 00
          0x80: 00 F8 00 24 03 E8 1B 11 07 D0 1E A2 09 C4 1F A9
          0x90: 0B B8 20 0F 0F A0 20 D3 13 88 21 6A 1B 58 21 A9
          0xA0: 1F 40 21 B8 27 10 21 3E 41 00 50 42 00 00 F8 00
          0xB0: 18 02 71 1D B0 04 E2 20 08 07 53 21 02 0E A6 22
          0xC0: 60 1D 4C 22 C4 27 10 22 C4 FF FF FF FF FF FF FF
          0xD0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xE0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xF0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    
        WIC Slot 0:
        HWIC MULTI VDSL over POTS
        Hardware Revision        : 1.0
        Top Assy. Part Number    : 800-34635-01
        Part Number              : 73-13372-02
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 02
        PCB Serial Number        : FOC16376SU3
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Product (FRU) Number     : EHWIC-VA-DSL-A
        Version Identifier       : V01
        CLEI Code                : COUIA8YCAA
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 07 1B 41 01 00 C0 46 03 20 00 87 4B 01
          0x10: 82 49 34 3C 02 42 41 30 88 00 00 00 00 02 02 C1
          0x20: 8B 46 4F 43 31 36 33 37 36 53 55 33 03 00 81 00
          0x30: 00 00 00 04 00 CB 92 45 48 57 49 43 2D 56 41 2D
          0x40: 44 53 4C 2D 41 00 00 00 00 89 56 30 31 20 D9 02
          0x50: 40 C1 C6 8A 43 4F 55 49 41 38 59 43 41 41 FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    
    
    Embedded Service Engine 0/0 :
      Total platform memory : 524288K bytes
      Total 2nd core memory : 0K bytes
      Start of physical address for 2nd core : 0x80000000
      Virtual address start of 2nd core memory : 0x0 - 0x0
      2nd core configured disabled
      L2 cache ways for 2nd core : 0

    sh inv
    Code:
    NAME: "CISCO1921/K9", DESCR: "CISCO1921/K9 chassis, Hw Serial#: ***********, Hw Revision: 1.0"
    PID: CISCO1921/K9      , VID: V05 , SN: **********
    
    NAME: "ADSL/VDSL over POTS supporting ADSL1, ADSL2, ADSL2+ and VDSL2 on Slot 0 SubSlot 0", DESCR: "ADSL/VDSL over POTS supporting ADSL1, ADSL2, ADSL2+ and VDSL2"
    PID: EHWIC-VA-DSL-A    , VID: V01 , SN: **********


    Am I doing something wrong here or is it likely to be a duff card?
     
    Last edited: 6 Apr 2019
  2. Caged

    Capodecina

    Joined: 18 Oct 2002

    Posts: 23,893

    There's a UK flag that can be set on the controller which may or may not help you, 'modem ukfeature'.
     
  3. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

    Thanks for the suggestion, caged. Sadly I've tried that earlier this evening, having found reference to it elsewhere relating to the 887VA.

    This is now the config that it's running from. I'm still getting the same output for sh controller vdsl 0/0/0 with no modem FW or modem phy
    Code:
    controller VDSL 0/0/0
     firmware filename flash:vdsl.bin.bdslfw
     modem UKfeature under controller vdsl 0/0/0
    no cdp run
    !
    !
    !
    !
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     no ip address
     ip tcp adjust-mss 1452
     duplex auto
     speed auto
     pppoe enable group global
     pppoe-client dial-pool-number 1
    !
    interface GigabitEthernet0/1
     ip address 192.168.0.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     ip tcp adjust-mss 1350
     duplex auto
     speed auto
     no mop enabled
    !
    interface ATM0/0/0
     no ip address
     shutdown
     no atm ilmi-keepalive
    !
    interface Ethernet0/0/0
     no ip address
     shutdown
    !
    interface Dialer1
     mtu 1492
     ip address negotiated
     ip access-group 101 in
     no ip unreachables
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     dialer pool 1
     ppp chap hostname bthomehub@btbroadband.com
     ppp chap password 7 1415060303092F23312A1337361115190205545856571A0D0C15
     ppp pap sent-username bthomehub@btbroadband.com password 7 0111120C54060307344E6E0B0D07051D0A08062B252066303A2F
    !
    ip forward-protocol nd
    !
    ip http server
    no ip http secure-server
    ip http client source-interface GigabitEthernet0/1
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static udp 192.168.0.3 9987 interface Dialer1 9987
    ip nat inside source static tcp 192.168.0.3 30033 interface Dialer1 30033
    ip nat inside source static tcp 192.168.0.3 10011 interface Dialer1 10011
    ip nat inside source static tcp 192.168.0.2 2564 interface Dialer1 2564
    ip nat inside source static tcp 192.168.0.2 2565 interface Dialer1 2565
    ip nat inside source static udp 192.168.0.2 2564 interface Dialer1 2564
    ip nat inside source static tcp 192.168.0.3 9988 interface Dialer1 9988
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 192.168.0.0 255.255.255.0 GigabitEthernet0/1
    
    I've found a few references to the same symptoms that I'm seeing but sadly no fixes.
    https://community.cisco.com/t5/rout...trange-output-of-show-controller/td-p/3764441
    https://community.cisco.com/t5/netw...itialized-cisco-1921-vdsl/m-p/3680610#M124969
    https://208.74.205.244/t5/routing/c887vam-vdsl-controller-vdsl-0-is-down-always/td-p/3764295
     
  4. Caged

    Capodecina

    Joined: 18 Oct 2002

    Posts: 23,893

    Is there anything in that flash:vdsllog.bin log file?

    Also try shifting it to the second EHWIC slot.
     
  5. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

    There is no vdsllog.bin in flash even though it suggests it’s created the file. Swapping slots was next on the agenda for today.
     
  6. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

    Behaviour no different in card slot 1 vs slot 0.

    Here is the bootup console info.
    Code:
    System Bootstrap, Version 15.0(1r)M16, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 2012 by cisco Systems, Inc.
    
    Total memory size = 512 MB
    CISCO1921/K9 platform with 524288 Kbytes of main memory
    Main memory is configured to 64 bit mode with ECC disabled
    
    
    Readonly ROMMON initialized
    program load complete, entry point: 0x80903000, size: 0x4c4a0
    
    
    IOS Image Load Test
    ___________________
    Digitally Signed Release Software
    program load complete, entry point: 0x81000000, size: 0x514b8d8
    Self decompressing the image : ############################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################# [OK]
    
    Smart Init is enabled
    smart init is sizing iomem
                     TYPE      MEMORY_REQ
              HWIC Slot 1      0x00200000
        Onboard devices &
             buffer pools      0x01E8F000
    -----------------------------------------------
                   TOTAL:      0x0208F000
    
    Rounded IOMEM up to: 36MB.
    Using 7 percent iomem. [36MB/512MB]
    
                  Restricted Rights Legend
    
    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.
    
               cisco Systems, Inc.
               170 West Tasman Drive
               San Jose, California 95134-1706
    
    
    
    Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.7(3)M2, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2018 by Cisco Systems, Inc.
    Compiled Wed 28-Mar-18 00:03 by prod_rel_team
    
    
    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
    
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    
    If you require further assistance please contact us by sending email to
    export@cisco.com.
    
    Cisco CISCO1921/K9 (revision 1.0) with 487424K/36864K bytes of memory.
    Processor board ID *********
    1 DSL controller
    1 Ethernet interface
    2 Gigabit Ethernet interfaces
    1 ATM interface
    1 terminal line
    DRAM configuration is 64 bits wide with parity disabled.
    255K bytes of non-volatile configuration memory.
    249840K bytes of USB Flash usbflash0 (Read/Write)
    
    SETUP: new interface ATM0/1/0 placed in "shutdown" state
    SETUP: new interface Ethernet0/1/0 placed in "shutdown" state
    
    Press RETURN to get started!
    
    *Jan  2 00:00:02.263: %SMART_LIC-6-AGENT_READY: Smart Agent for Licensing is initialized
    *Jan  2 00:00:02.591: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = c1900 Next reboot level = ipbasek9 and License = ipbasek9
    *Apr  7 12:08:05.127: c3600_scp_set_dstaddr2_idb(185)add = 80 name is Embedded-Service-Engine0/0
    *Apr  7 12:08:22.035: %LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to reset
    *Apr  7 12:08:22.035: %LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to reset
    *Apr  7 12:08:22.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/1/0, changed state to down
    *Apr  7 12:08:23.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
    *Apr  7 12:08:23.035: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
    *Apr  7 12:08:24.115: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up
    *Apr  7 12:08:24.123: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up
    *Apr  7 12:08:27.243: %USBFLASH-5-CHANGE: usbflash0 has been inserted!
    *Apr  7 12:08:31.007: %SYS-5-CONFIG_I: Configured from memory by console
    *Apr  7 12:08:31.147: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to up
    *Apr  7 12:08:32.175: %LINK-5-CHANGED: Interface Embedded-Service-Engine0/0, changed state to administratively down
    *Apr  7 12:08:33.015: %LINK-5-CHANGED: Interface ATM0/1/0, changed state to administratively down
    *Apr  7 12:08:33.071: %LINK-5-CHANGED: Interface Ethernet0/1/0, changed state to administratively down
    *Apr  7 12:08:33.175: %LINEPROTO-5-UPDOWN: Line protocol on Interface Embedded-Service-Engine0/0, changed state to down
    *Apr  7 12:08:34.099: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1/0, changed state to down
    *Apr  7 12:08:35.199: %SYS-5-RESTART: System restarted --
    Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.7(3)M2, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2018 by Cisco Systems, Inc.
    Compiled Wed 28-Mar-18 00:03 by prod_rel_team
    *Apr  7 12:08:35.199: %SNMP-5-COLDSTART: SNMP agent on host Cisco-1921 is undergoing a cold start
    *Apr  7 12:08:36.839: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
    *Apr  7 12:08:36.839: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
    *Apr  7 12:08:38.867: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
    *Apr  7 12:08:38.871: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
    *Apr  7 12:08:38.995: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
    *Apr  7 12:08:40.259: %PNP-6-PNP_DISCOVERY_STOPPED: PnP Discovery stopped (Startup Config Present)
    Cisco-1921>
     
    Last edited: 18 Apr 2019
  7. Caged

    Capodecina

    Joined: 18 Oct 2002

    Posts: 23,893

    Isn't that saying your HWIC is at ATM0/1/0 and not VDSL 0/0/0?
     
  8. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

    The card's interfaces are ATM0/1/0 and ethernet0/1/0 but the card controller is VDSL 0/1/0. If the card is in slot 0 they are all 0/0/0, moving it to slot 1 changed them all to 0/1/0. I didn't modify the config before moving the card to the other slot, hence the invalid inputs.
     
  9. Caged

    Capodecina

    Joined: 18 Oct 2002

    Posts: 23,893

    In your config ATM0/0/0 is shutdown
     
  10. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

  11. Caged

    Capodecina

    Joined: 18 Oct 2002

    Posts: 23,893

    I'm out of ideas then really. I presume you get no lights on the WIC if you connect it to your line?

    Can you do a loopback test on DSL or is that just on PRI circuits?
     
  12. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

    The symptoms and the lack of a modem FW, modem PHY and Vendor version suggest a hardware issue to me, so I've contacted the seller. Hopefully I'll be able to sort out a replacement.
     
  13. mad_allan

    Mobster

    Joined: 17 Dec 2003

    Posts: 3,215

    Location: Peterborough

    Have you checked with @chrisd ? I think he had the same setup.
     
  14. mad_allan

    Mobster

    Joined: 17 Dec 2003

    Posts: 3,215

    Location: Peterborough

    Also, just checking you have operating mode auto set on the VDSL controller?
     
  15. Caged

    Capodecina

    Joined: 18 Oct 2002

    Posts: 23,893

    If you were in London I could lend you one of those cards to play with, but I doubt I can just make it disappear from our office entirely
     
  16. Bouton Aide

    Caporegime

    Joined: 9 Aug 2008

    Posts: 25,990

    Last edited: 9 Apr 2019
  17. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

    The supplier seemed to agree with my conclusions and are sending a replacement card. Will see how things go when it arrives.
     
  18. Caged

    Capodecina

    Joined: 18 Oct 2002

    Posts: 23,893

    It's always annoying trying to diagnose a suspected hardware issue when you don't have spare parts, because you don't want to be one of "those guys" who RMAs things that they just don't know how to use.
     
  19. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

    Replacement arrived yesterday. Will be testing it out this evening. I've got my fingers crossed I've not been one of "those guys" and this one initialises and works perfectly.
     
  20. Kei

    Mobster

    Joined: 24 Oct 2008

    Posts: 2,606

    Location: South Wales

    I've fitted the replacement modem and re-applied my config and it worked first time, although I had some issues with a lot of websites timing out. I think that may have been caused by my not having "ip tcp adjust-mss 1452" on interface GigabitEthernet0/1. It used to be set at 1350. It all seems to be working perfectly since I put it back in.

    Seeing this controller info was the best thing in the world.
    Code:
    Controller VDSL 0/0/0 is UP
    
    Daemon Status:           Up
    
                            XTU-R (DS)              XTU-C (US)
    Chip Vendor ID:         'BDCM'                   'IFTN'
    Chip Vendor Specific:   0x0000                   0xB206
    Chip Vendor Country:    0xB500                   0xB500
    Modem Vendor ID:        'CSCO'                   '    '
    Modem Vendor Specific:  0x4602                   0x0000
    Modem Vendor Country:   0xB500                   0x0000
    Serial Number Near:    FOC16390RTR 1921/K9  15.2(4)M
    Serial Number Far:     5501570926
    Modem Version Near:    15.2(4)M
    Modem Version Far:     0xb206
    
    Modem Status:            TC Sync (Showtime!)
    DSL Config Mode:         AUTO
    Trained Mode:            G.993.2 (VDSL2) Profile 17a
    TC Mode:                 PTM
    Selftest Result:         0x00
    DELT configuration:      disabled
    DELT state:              not running
    Trellis:                 ON                       ON
    SRA:                     disabled                        disabled
     SRA count:              0                       0
    Bit swap:                enabled                         enabled
     Bit swap count:         0                       0
    Line Attenuation:         0.0 dB                  0.0 dB
    Signal Attenuation:       0.0 dB                  0.0 dB
    Noise Margin:             6.8 dB                  9.3 dB
    Attainable Rate:        65748 kbits/s            23491 kbits/s
    Actual Power:             3.2 dBm                 3.2 dBm
    Per Band Status:        D1      D2      D3      U0      U1      U2      U3
    Line Attenuation(dB):   8.1     19.2    31.7    0.1     14.8    22.9    N/A
    Signal Attenuation(dB): 8.1     19.2    31.7    0.1     14.6    22.9    N/A
    Noise Margin(dB):       6.6     6.7     6.8     10.5    9.4     9.2     N/A
    Total FECC:             0                        2
    Total ES:               0                        0
    Total SES:              0                        0
    Total LOSS:             0                        0
    Total UAS:              39                       39
    Total LPRS:             0                        0
    Total LOFS:             0                        0
    Total LOLS:             0                        0
    
    Full inits:             1
    Failed full inits:      0
    Short inits:            0
    Failed short inits:     1
    
    Firmware        Source          File Name (version)
    --------        ------          -------------------
    VDSL            embedded        VDSL_LINUX_DEV_01212008 (1)
    
    Modem FW  Version:      130205_1433-4.02L.03.A2pv6C035j.d23j
    Modem PHY Version:      A2pv6C035j.d23j
    Vendor Version:         Ap6v35j.23j 68
    
    
                      DS Channel1     DS Channel0   US Channel1       US Channel0
    Speed (kbps):             0            62918             0             18999
    SRA Previous Speed:       0                0             0                 0
    Previous Speed:           0                0             0                 0
    Reed-Solomon EC:          0                0             0                 2
    CRC Errors:               0                0             0                 0
    Header Errors:            0                0             0                 0
    Interleave (ms):       0.00             0.00          0.00              0.00
    Actual INP:            0.00             0.00          0.00              0.00
    
    Training Log :  Stopped
    Training Log Filename : flash:vdsllog.bin
    

    Config
    Code:
    
    !
    ! Last configuration change at 21:02:49 UTC Thu Apr 18 2019
    version 15.2
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Cisco-1921
    !
    boot-start-marker
    warm-reboot
    boot-end-marker
    !
    !
    enable secret 5 ****
    enable password 7 ****
    !
    no aaa new-model
    !
    ip cef
    !
    !
    !
    !
    ip dhcp pool main_dhcp_pool
     network 192.168.0.0 255.255.255.0
     default-router 192.168.0.1
     dns-server 194.72.0.114 62.6.40.162
    !
    ip dhcp pool Kei-PC
     host 192.168.0.2 255.255.255.0
     client-identifier ****
     client-name Kei-PC
    !
    ip dhcp pool Humax
     host 192.168.0.4 255.255.255.0
     client-identifier ****
     client-name Humax
    !
    ip dhcp pool Kei-NAS
     host 192.168.0.3 255.255.255.0
     hardware-address ****
     client-name Kei-NAS
    !
    ip dhcp pool Server
     host 192.168.0.100 255.255.255.0
     hardware-address ****
    !
    ip dhcp pool Marantz
     host 192.168.0.5 255.255.255.0
     client-identifier ****
    !
    ip dhcp pool Printer
     host 192.168.0.6 255.255.255.0
     client-identifier ****
     client-name Printer
    !
    ip dhcp pool Panasonic
     host 192.168.0.7 255.255.255.0
     client-identifier ****
    !
    ip dhcp pool RPI3
     host 192.168.0.8 255.255.255.0
     client-identifier ****
    !
    !
    !
    ip domain name WesNet
    ip name-server 194.72.0.114
    ip name-server 62.6.40.162
    no ipv6 cef
    multilink bundle-name authenticated
    !
    !
    !
    license udi pid CISCO1921/K9 sn FCZ1810C0V2
    !
    !
    archive
     path ftp://****:****@192.168.0.3/Cisco-1921/$h
     write-memory
     time-period 10080
    !
    !
    controller VDSL 0/0/0
     modem UKfeature under controller vdsl 0/0/0
    !
    !
    !
    !
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     ip address 192.168.0.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     ip tcp adjust-mss 1452
     duplex auto
     speed auto
     no mop enabled
    !
    interface ATM0/0/0
     no ip address
     shutdown
     no atm ilmi-keepalive
    !
    interface Ethernet0/0/0
     no ip address
    !
    interface Ethernet0/0/0.101
     encapsulation dot1Q 101
     ip tcp adjust-mss 1452
     pppoe enable group global
     pppoe-client dial-pool-number 1
    !
    interface Dialer1
     mtu 1492
     ip address negotiated
     ip access-group 101 in
     no ip unreachables
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     dialer pool 1
     ppp chap hostname bthomehub@btbroadband.com
     ppp chap password 7 1415060303092F23312A1337361115190205545856571A0D0C15
     ppp pap sent-username bthomehub@btbroadband.com password 7 ****
    !
    ip forward-protocol nd
    !
    ip http server
    no ip http secure-server
    ip http client source-interface GigabitEthernet0/1
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static udp 192.168.0.3 9987 interface Dialer1 9987
    ip nat inside source static tcp 192.168.0.3 30033 interface Dialer1 30033
    ip nat inside source static tcp 192.168.0.3 10011 interface Dialer1 10011
    ip nat inside source static tcp 192.168.0.2 2564 interface Dialer1 2564
    ip nat inside source static tcp 192.168.0.2 2565 interface Dialer1 2565
    ip nat inside source static udp 192.168.0.2 2564 interface Dialer1 2564
    ip nat inside source static tcp 192.168.0.3 9988 interface Dialer1 9988
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 192.168.0.0 255.255.255.0 GigabitEthernet0/1
    !
    access-list 1 remark INTERNET-ACCESS
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 2 remark ONLY PERMIT TELNET FROM INTERNAL IPs
    access-list 2 permit 192.168.0.0 0.0.0.255
    access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
    access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
    access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 101 deny   ip 255.0.0.0 0.255.255.255 any
    access-list 101 deny   ip 248.0.0.0 7.255.255.255 any
    access-list 101 deny   ip host 0.0.0.0 any
    access-list 101 deny   ip host 255.255.255.255 any
    access-list 101 deny   tcp any any eq telnet
    access-list 101 deny   udp any any range 33400 34400
    access-list 101 permit icmp any any net-unreachable
    access-list 101 permit icmp any any host-unreachable
    access-list 101 permit icmp any any port-unreachable
    access-list 101 permit icmp any any packet-too-big
    access-list 101 permit icmp any any administratively-prohibited
    access-list 101 permit icmp any any source-quench
    access-list 101 permit icmp any any ttl-exceeded
    access-list 101 permit icmp any any echo-reply
    access-list 101 permit tcp any any established
    access-list 101 permit udp any any
    access-list 101 permit tcp any any eq 54021
    access-list 101 permit tcp any any eq 54022
    access-list 101 permit tcp any any eq 2564
    !
    !
    snmp-server community WesNet RO
    snmp-server enable traps entity-sensor threshold
    !
    control-plane
    !
    !
    no vstack
    !
    line con 0
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     access-class 2 in
     password 7 ****
     login
     transport input all
    !
    scheduler allocate 20000 1000
    !
    end
    I've got the feeling that some of the config has been lost over the last few months as ACL 2 doesn't look right to me. Anyone spot anything daft in the config, let me know. I realise I've never bothered to setup users on it as it's never really bothered me.