Cisco 1921 + VDSL HWIC issue

Caporegime
Joined
18 Oct 2002
Posts
26,098
I have no idea if that Cisco supports baby jumbo frames, but the Openreach VDSL infrastructure does. I can run full 1500 byte packets over a Vodafone business FTTC link by setting the interface MTU to 1508.
 

Kei

Kei

Soldato
OP
Joined
24 Oct 2008
Posts
2,750
Location
South Wales
I have no idea if that Cisco supports baby jumbo frames, but the Openreach VDSL infrastructure does. I can run full 1500 byte packets over a Vodafone business FTTC link by setting the interface MTU to 1508.
Well I've seen others mention it elsewhere, so I've given it a go. Not had any issues so far.

Tweaked config.
Code:
Building configuration...

Current configuration : 5197 bytes
!
! Last configuration change at 09:49:18 UTC Fri Apr 19 2019
version 15.2
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cisco-1921
!
boot-start-marker
warm-reboot
boot-end-marker
!
!
enable secret 5 ****
enable password 7 ****
!
no aaa new-model
!
ip cef
!
!
!
!
ip dhcp pool main_dhcp_pool
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 dns-server 194.72.0.114 62.6.40.162
!
ip dhcp pool Kei-PC
 host 192.168.0.2 255.255.255.0
 client-identifier ****
 client-name Kei-PC
!
ip dhcp pool Humax
 host 192.168.0.4 255.255.255.0
 client-identifier ****
 client-name Humax
!
ip dhcp pool Kei-NAS
 host 192.168.0.3 255.255.255.0
 hardware-address ****
 client-name Kei-NAS
!
ip dhcp pool Server
 host 192.168.0.100 255.255.255.0
 hardware-address ****
!
ip dhcp pool Marantz
 host 192.168.0.5 255.255.255.0
 client-identifier ****
!
ip dhcp pool Printer
 host 192.168.0.6 255.255.255.0
 client-identifier ****
 client-name Printer
!
ip dhcp pool Panasonic
 host 192.168.0.7 255.255.255.0
 client-identifier ****
!
ip dhcp pool RPI3
 host 192.168.0.8 255.255.255.0
 client-identifier ****
!
!
!
ip domain name WesNet
ip name-server 194.72.0.114
ip name-server 62.6.40.162
no ipv6 cef
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn FCZ1810C0V2
!
!
archive
 path ftp://****@192.168.0.3/Cisco-1921/$h
 write-memory
 time-period 10080
!
!
controller VDSL 0/0/0
 modem UKfeature under controller vdsl 0/0/0
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 no mop enabled
!
interface ATM0/0/0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Ethernet0/0/0
 mtu 1508
 no ip address
!
interface Ethernet0/0/0.101
 encapsulation dot1Q 101
 pppoe enable group global
 pppoe-client dial-pool-number 1
 pppoe-client ppp-max-payload 1500
!
interface Dialer1
 ip address negotiated
 ip access-group 101 in
 no ip unreachables
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp chap hostname [email protected]
 ppp chap password 7 ****
 ppp pap sent-username [email protected] password 7 ****
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
ip http client source-interface GigabitEthernet0/1
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static udp 192.168.0.3 9987 interface Dialer1 9987
ip nat inside source static tcp 192.168.0.3 30033 interface Dialer1 30033
ip nat inside source static tcp 192.168.0.3 10011 interface Dialer1 10011
ip nat inside source static tcp 192.168.0.2 2564 interface Dialer1 2564
ip nat inside source static tcp 192.168.0.2 2565 interface Dialer1 2565
ip nat inside source static udp 192.168.0.2 2564 interface Dialer1 2564
ip nat inside source static tcp 192.168.0.3 9988 interface Dialer1 9988
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.0.0 255.255.255.0 GigabitEthernet0/1
!
access-list 1 remark INTERNET-ACCESS
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 remark ONLY PERMIT TELNET FROM INTERNAL IPs
access-list 2 permit 192.168.0.0 0.0.0.255
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 deny   ip 255.0.0.0 0.255.255.255 any
access-list 101 deny   ip 248.0.0.0 7.255.255.255 any
access-list 101 deny   ip host 0.0.0.0 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   tcp any any eq telnet
access-list 101 deny   udp any any range 33400 34400
access-list 101 permit icmp any any net-unreachable
access-list 101 permit icmp any any host-unreachable
access-list 101 permit icmp any any port-unreachable
access-list 101 permit icmp any any packet-too-big
access-list 101 permit icmp any any administratively-prohibited
access-list 101 permit icmp any any source-quench
access-list 101 permit icmp any any ttl-exceeded
access-list 101 permit icmp any any echo-reply
access-list 101 permit tcp any any established
access-list 101 permit udp any any
access-list 101 permit tcp any any eq 54021
access-list 101 permit tcp any any eq 54022
access-list 101 permit tcp any any eq 2564
!
!
snmp-server community WesNet RO
snmp-server enable traps entity-sensor threshold
!
control-plane
!
!
no vstack
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 access-class 2 in
 password 7 ****
 login
 transport input all
!
scheduler allocate 20000 1000
!
end
 
Associate
Joined
9 Jun 2019
Posts
4
Nice, I hope a couple months bump for this thread won't tick too many people off, and I hope this will help somebody....

I recently did the same, If you want to use DSLStats, add the following to your config:
Code:
service internal
alias exec xdslctl test vdsl 0/0/0 modem exec /bin/xdslctl


ivwh7t.jpg

I'm bridged to another router and just using this as a modem for the moment. ^ The stats were better when it was colder xD
give us an update if you're using dslstats already! That was half the reason I went to cisco, and the other half was watching the attainable rate go from 10.5mbit/s to around 12 (over 12 with adsl2+ enabled) Those b@stards better upgrade the backhaul soon, I'm chomping at the bit!

Here's what I'm working with, hoping to get another va-dsl-a and go for double bonded connections when they upgrade the equipment...
Code:
Controller VDSL 0/0/0 is UP

Daemon Status:           Up

                        XTU-R (DS)              XTU-C (US)
Chip Vendor ID:         'BDCM'                   'IFTN'
Chip Vendor Specific:   0x0000                   0x71B0
Chip Vendor Country:    0xB500                   0xB500
Modem Vendor ID:        'CSCO'                   '    '
Modem Vendor Specific:  0x4602                   0x0000
Modem Vendor Country:   0xB500                   0x0000
Serial Number Near:    xxxxxxxxx 2911/K9 15.7(3)M3
Serial Number Far:
Modem Version Near:    15.7(3)M3
Modem Version Far:     0x71b0

Modem Status:            TC Sync (Showtime!)

DSL Config Mode:         AUTO
Trained Mode:   G.992.1 (ADSL) Annex A
TC Mode:                 ATM
Selftest Result:         0x00
DELT configuration:      enabled
DELT state:              successful

Full inits:             2
Failed full inits:      0
Short inits:            0
Failed short inits:     0

Firmware        Source          File Name
--------        ------          ----------
VDSL            user config     flash0:23mar2017_39m_B_38u_24o_rc1_sdk_4.14l.04a-j.bin

Modem FW  Version:      4.14L.04A
Modem PHY Version:      A2pv6C039m.d24o_rc1
Trellis:                 ON                       ON
SRA:                     disabled                disabled
 SRA count:              0                       0
Bit swap:                enabled                 enabled
 Bit swap count:         0                       1660
Line Attenuation:        25.5 dB                 14.5 dB
Signal Attenuation:      25.5 dB                  0.0 dB
Noise Margin:            18.3 dB                 17.0 dB
Attainable Rate:        11992 kbits/s            1352 kbits/s
Actual Power:            19.6 dBm                10.5 dBm
Total FECC:             0                        0
Total ES:               0                        0
Total SES:              0                        0
Total LOSS:             0                        0
Total UAS:              22                       22
Total LPRS:             0                        0
Total LOFS:             0                        0
Total LOLS:             0                        0


                  DS Channel1     DS Channel0   US Channel1       US Channel0
Speed (kbps):             0             6944             0              1024
SRA Previous Speed:       0                0             0                 0
Previous Speed:           0             6944             0              1024
Total Cells:              0        645474777             0                 0
User Cells:               0        109732266             0                 0
Reed-Solomon EC:          0                0             0                 0
CRC Errors:               0                0             0                 0
Header Errors:            0                0             0                 0
Interleave (ms):       0.00             0.25          0.00              0.25
Actual INP:            0.00             0.00          0.00              0.00
 
Last edited:
Associate
Joined
2 Oct 2004
Posts
654
Location
South East
I am trying to use DSLStats to monitor my 1921 with 2xVDSL lines, I have exposed the xdslctl command in the router but having issues getting the DSLStats app to login.

Assume you are using special login, would you be able to share a shot of your config page (minus passwords) :)
 
Associate
Joined
9 Jun 2019
Posts
4
Not sure how many password prompts you have before you get in, I just have the one with my current config. Security isn't an issue for me as far as redundant passwords for the terminal etc. since I'm bridging the modem to another router, and I have a seperate interface dedicated to management and logging.

As long as you have aliased your command so DSLStats can use 'xdslctl' at the main prompt, and get past (my guess) your second password, everything should work. :D

Oh, and I never could get the windows version of DSLStats working, not that I would use it anyway... it crashes after the first status update on both of my windows PCs.
1znpz5c.jpg
 
Last edited:

Kei

Kei

Soldato
OP
Joined
24 Oct 2008
Posts
2,750
Location
South Wales
I've tried this on mine and get "timeout while retrieving stats". Trying to run xdslctl on the router via telnet outside of exec results in the following message.

Code:
Cisco-1921>xdslctl
test vdsl 0/0/0 modem exec /bin/xdslctl
  ^
% Invalid input detected at '^' marker.


My config contains the two lines:
Code:
service internal
alias exec xdslctl test vdsl 0/0/0 modem exec /bin/xdslctl
 
Associate
Joined
9 Jun 2019
Posts
4
Cisco-1921>
_________^

Is this your problem? Try checking the box 'requires command to enter shell' and use 'en' in your settings, I think you have to be in privileged mode for it to work. :D

Is that what you meant by "outside of exec" or did you mean by using the full 'test vdsl 0/0/0 modem exec /bin/xdslctl' command?
 
Last edited:

Kei

Kei

Soldato
OP
Joined
24 Oct 2008
Posts
2,750
Location
South Wales
Cisco-1921>
_________^

Is this your problem? Try checking the box 'requires command to enter shell' and use 'en' in your settings, I think you have to be in privileged mode for it to work. :D

Is that what you meant by "outside of exec”
That is what I meant. I’d already tried using en command to enter shell but dslstats then has problems logging in. I tried to set something in special login options but it didn’t work. It’d be nice to know what @iwrox did with special login.
 
Back
Top Bottom