1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Datawrite Titanium 16x speed problem

Discussion in 'Optical Storage & Writing' started by Chong Warrior, 15 Feb 2006.

  1. Chong Warrior

    Capodecina

    Joined: 18 Oct 2002

    Posts: 12,062

    Location: Manchester

    This is the first time I've ever had a problem with media, I'm baffled by the fact my drive, an NEC2500A, won't even acknowledge there's a disc in the drive!

    The only time it will is with some software I don't think I can name on here, it tells me the Dye is MCC 03RG20. I've now tried numerous burning programs and none will even see that there's a disc there :(

    I've tried 3 new firmwares, including Herrie's 1.07, 1.07b and a new one called 1.08 3-2.

    I've burnt hundreds of problem free disc's, the last batch I had were MCC 02RG20 coded and they worked perfectly. Anyone else tried these?

    They're sold on this site aswell but I didn't get mine from here.
     
  2. Rambaud

    Wise Guy

    Joined: 15 Apr 2003

    Posts: 1,978

    Location: Hertfordshire

    I assume it works with other media?

    If so, it seems likely to be a firmware issue - it is an old drive. :)

    I have a BenQ 1640 which does not recognise some new media at the moment e.g. 8x DVD+RW.

    Does your NEC 2500 write at 16x, as it a 4x drive? Perhaps with hacked firmware?