1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Competitor rules

    Please remember that any mention of competitors, hinting at competitors or offering to provide details of competitors will result in an account suspension. The full rules can be found under the 'Terms and Rules' link in the bottom right corner of your screen. Just don't mention competitors in any way, shape or form and you'll be OK.

    Dismiss Notice

Dodgy or faulty X800 cooler? Making noises.

Discussion in 'Graphics Cards' started by mc_bob, 14 Jan 2006.

  1. mc_bob

    Banned

    Joined: 29 Aug 2005

    Posts: 1,553

    Location: Reppin' up North London

    Dodgy or faulty X800 cooler? Making noises. What should I do? Please answer ASAP.

    Hi,
    I bought a graphics card about 10 days ago, it was a:
    HIS Excalibur ATI Radeon X800 GTO ICEQII TURBO 256MB GDDR3 TV-Out/DVI (PCI-Express) - Retail (RX800GTO-256ICEQT) (GX-044-HT)
    The fan on it has started making noises. Tbh i'm not sure if it done this as soon as i got it. It sounds as if the bearings are faulty as it's the noisiest thing in the case now. If I change the an speed from 10% to about 90% the noise is there. It may be resonating but I doubt it, I will try taking it out and looking. Should I send it back for a replacement?
    What should I do?
    Thanks


    MC_Bob

    E: I've also been reading reviews, there must be something wrong since a lot of people say its is very quiet and inaudible.
     
    Last edited: 14 Jan 2006
  2. mc_bob

    Banned

    Joined: 29 Aug 2005

    Posts: 1,553

    Location: Reppin' up North London

    I would like a quick reply so I would know what steps to take.
    Thanks a lot.

    MC_Bob
     
  3. mc_bob

    Banned

    Joined: 29 Aug 2005

    Posts: 1,553

    Location: Reppin' up North London

    Another bump, I really need an answer.

    Thanks

    MC_Bob
     
  4. dale1uk

    Wise Guy

    Joined: 15 Nov 2005

    Posts: 2,159

    Location: Newcastle

    does it sound loud all the time or only when spinning up at top speed?? the fan on my x850xt is fairly quiet at low rpm but like a hoover at 100%
     
  5. mc_bob

    Banned

    Joined: 29 Aug 2005

    Posts: 1,553

    Location: Reppin' up North London

    The loud setting is fairly quiet, it's the clicking, it sounds as if the fan isn't center and is swinging round unbalanced.

    MC_Bob

    I also noticed it's made by Artic Cooling so I wouldn't expect it to do this if it was working correctly since they specialise in this.
     
  6. dale1uk

    Wise Guy

    Joined: 15 Nov 2005

    Posts: 2,159

    Location: Newcastle

    sounds ike a dodgy fan then, get it sent back and the replacement should be alot better.
     
  7. mc_bob

    Banned

    Joined: 29 Aug 2005

    Posts: 1,553

    Location: Reppin' up North London

    Ok cool.
    How would I go about this?
    Do I notify Overclockers first then send it?

    Thanks

    MC_Bob