1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forums on a Suse 9.2 server

Discussion in 'Linux & Open Source' started by Loki, 16 Jan 2006.

  1. Loki

    Asus Rep

    Joined: 17 Nov 2004

    Posts: 9,781

    Location: The Republic

    I run some forums off a SUSE 9.2 Dedicated server in a data centre.

    This morning the server had to be powercycled. Now the guy who would normally manage all stuff like this is away for a few days. I also know that the forum process had to be restarted last time we had a power cycle. So I guess h e didnt set it to autoboot.

    Does anyone know the command for getting this process up and running again. apologies in advance if the info provided is a bit sketchy
     
  2. Burbleflop

    PermaBanned

    Joined: 7 May 2003

    Posts: 4,247

    Location: Away from here

    What is the forum? It might just be a case of starting Apache (or someother web server), in which case something like /etc/rc.d/httpd start might do the trick.

    If that works, do:

    cd /etc/rc.d
    chkconfig httpd on

    Apache will then start at boot time.
     
  3. Loki

    Asus Rep

    Joined: 17 Nov 2004

    Posts: 9,781

    Location: The Republic

    I think it is apache.

    Is there any command I can use in putty or webmin to start the webserve at all ?

    I would like to start the webserver without the need for rebooting the entire box if at all possible.
     
    Last edited: 16 Jan 2006
  4. Burbleflop

    PermaBanned

    Joined: 7 May 2003

    Posts: 4,247

    Location: Away from here

    If you can SSH to the server (using putty) then you can use the commands I listed.

    In Webmin, go to System then Bootup and Shutdown. Look down the list and you should see Apache (or httpd) listed there. Select it and choose 'start selected' from the bottom of the page.
     
  5. Loki

    Asus Rep

    Joined: 17 Nov 2004

    Posts: 9,781

    Location: The Republic

    I went into webmin. Apache and httpd was not there. So I tried the command line by line as suggested in putty.

    I got the config on screen and tried the last bit but I got an error message saying-bash: httpd: command not found
     
  6. Burbleflop

    PermaBanned

    Joined: 7 May 2003

    Posts: 4,247

    Location: Away from here

    What other services were listed in Webmin? The exact way of starting Apache will vary depending upon distro (if you use an RPM, deb or whatever) or compile it from source.

    As root, run the command 'find / -name httpd -print' and post the results - you're looking for on within a bin directory. It may be that a startup script hasn't been created (would explain httpd not being in /etc/rc.d or there being no webmin service).

    If you find httpd, cd to that directory and do './httpd start'
     
  7. Loki

    Asus Rep

    Joined: 17 Nov 2004

    Posts: 9,781

    Location: The Republic

    alan3:/ # find / -name httpd -print
    /etc/httpd
    /usr/local/apache2/bin/httpd
    /home/src/httpd-2.0.54/.libs/httpd
    /home/src/httpd-2.0.54/httpd


    I CD to /usr/local/apache2/bin/

    tried cd httpd and it says not a directory

    so i did ./httpd start in the bin directory and I got the following

    Usage: ./httpd [-D name] [-d directory] [-f file]
    [-C "directive"] [-c "directive"]
    [-k start|restart|graceful|stop]
    [-v] [-V] [-h] [-l] [-L] [-t] [-S]
    Options:
    -D name : define a name for use in <IfDefine name> directives
    -d directory : specify an alternate initial ServerRoot
    -f file : specify an alternate ServerConfigFile
    -C "directive" : process directive before reading config files
    -c "directive" : process directive after reading config files
    -e level : show startup errors of level (see LogLevel)
    -E file : log startup errors to file
    -v : show version number
    -V : show compile settings
    -h : list available command line options (this page)
    -l : list compiled in modules
    -L : list available configuration directives
    -t -D DUMP_VHOSTS : show parsed settings (currently only vhost settings)
    -S : a synonym for -t -D DUMP_VHOSTS
    -t : run syntax check for config files
     
  8. Burbleflop

    PermaBanned

    Joined: 7 May 2003

    Posts: 4,247

    Location: Away from here

    Try ./httpd -k start

    I'm a bit rusty with Apache2, I'm still using 1.3.
     
  9. Loki

    Asus Rep

    Joined: 17 Nov 2004

    Posts: 9,781

    Location: The Republic

    Burbleflop that works fantastic and it is up. Your help is very much appreciated

    Only problem now is that when we try and connect to the forums it comes up with a message phpBB Critical error could not connect to the db. Would that mean MySQL needs booting as well.

    I hate it when people are away
     
  10. Burbleflop

    PermaBanned

    Joined: 7 May 2003

    Posts: 4,247

    Location: Away from here

    Ah, I forgot about checking the database.

    Have a look in /etc/rc.d/ and see if there is a file called mysql in there. If there is do a './mysql start'

    Then do 'chkconfig mysql start' while you're still in /etc/rc.d/ to set it to start at boot time.

    In the bin directory (where you found httpd), is there a file called apachectl? That should be the bases of a startup script that you can copy to /etc/rc.d/ to have Apache start at boot time.
     
  11. Loki

    Asus Rep

    Joined: 17 Nov 2004

    Posts: 9,781

    Location: The Republic

    i can cd to it in putty and tried the command with no success

    I looked in webmin for the file manager and for rc.d there is one file with like an arrow next to it. Other rc.d files are readme and status

    no MySql file in there
     
  12. Burbleflop

    PermaBanned

    Joined: 7 May 2003

    Posts: 4,247

    Location: Away from here

    Did you look for MySql or mysql? Remember that Linux is case sensitive. You should also be able to start MySQL from the bootup & shutdown page of Webmin, under System.
     
  13. Loki

    Asus Rep

    Joined: 17 Nov 2004

    Posts: 9,781

    Location: The Republic

    I looked for both. MySql returns no hits at all on there.

    When I look in webmin for start up and shutdown there is no option for any mysql db :confused:
     
  14. Burbleflop

    PermaBanned

    Joined: 7 May 2003

    Posts: 4,247

    Location: Away from here

    Other than waiting for someone who knows the system to come back, I'm not sure what else to suggest.
     
  15. memyselfandi

    Sgarrista

    Joined: 10 Oct 2005

    Posts: 8,680

    Location: Nottingham

    Looking at the SuSE 9.3 system I have access to it would appear that to start Apache 2 and MySql you would normally use the following commands, (assuming they have not been set to start on boot automatically).

    (via putty)
    cd /etc/init.d
    ./apache2 start
    ./mysql start

    Or SUSE normally has some links setup so if you have /usr/sbin in your path you can type:
    rcapache2 start
    rcmysql start

    Tim
     
  16. Berserker

    Man of Honour

    Joined: 4 Nov 2002

    Posts: 15,448

    Location: West Berkshire

    Sounds like he's running a custom build of Apache, not the SuSE-supplied one, so that won't work. The same could be true of MySQL as well, in which case it would also be in /usr/local.

    It's in /usr/local/mysql/bin on my system (also a custom build). If there's a mysqld_safe file in there, try running that.