1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP: Cannot get wifi to work on Windows 7

Discussion in 'Networks & Internet Connectivity' started by .Lethal, 7 Oct 2009.

  1. .Lethal

    Soldato

    Joined: 8 Jun 2005

    Posts: 6,937

    Location: United Kingdom

    Hi all, not 100% sure if this is the right section of the forum to post, if its wrong please direct to the right area :)

    Right, I have an Asus P5K Premium motherboard and I am trying to get WiFi to work with Windows 7.

    Last night I used the router wired to download the driver via Windows update which worked as normal and confirmed via device manager that this was now working.

    I then disconnected the router put it back in the correct place and set the PC back up in its normal spot and fired up.

    I then tried to connect my to my router, I could find the Router (eventually, it wasnt so simple). I then entered my keycode to gain access but when it would try to connect to gain internet it fails and then goes through the usual generic crap of turning router of for 30secs, try restarting it etc etc which does not work.

    The keycode is correct, for the sake of it I tried putting in the wrong code and it would inform me that it is incorrect, when I entered the right one, it would proceed to try and connect. So this can be ruled out :)

    Is the driver from Microsofts update faulty? Also, the signal from my PC is quite weak when trying to find the Router (2 bars where as the crap laptop I have has max signal strength!). So I am wondering if this is apart of the problem.

    Any help would be very helpful! I will be googling some more today to try and resolve it and will post results if they happen.

    Is there a direct link to a driver that does work for other people? It is a Realtek WiFi for the Asus P5K Premium motherboard.

    Thanks for reading.
     
  2. Lanz

    Soldato

    Joined: 26 Nov 2002

    Posts: 6,855

    Location: Romford

    Disabled/enable the WLAN card, delete any saved wireless profiles and try again.
     
  3. bledd

    Don

    Joined: 21 Oct 2002

    Posts: 46,757

    Location: Parts Unknown

    get latest driver from whoever makes it
     
  4. Lanz

    Soldato

    Joined: 26 Nov 2002

    Posts: 6,855

    Location: Romford

    Oops, wrong msg, deleted
     
  5. .Lethal

    Soldato

    Joined: 8 Jun 2005

    Posts: 6,937

    Location: United Kingdom

    That is the normal thing I would do. However, there website would not load. If you have used Realteks.tw website you would know how dire it can be at times :)

    I did google various things to try and get a solution but it was eaither outdated information or not relavent. I will try again now and hope I get something this time round.
     
  6. .Lethal

    Soldato

    Joined: 8 Jun 2005

    Posts: 6,937

    Location: United Kingdom

    Problem solved.

    I needed to connect the wire/antenna to the back of the PC into the motherboard :eek:

    Man sometimes it is just the simple things ...

    BTW you can get the latest Realtek driver via Windows update.

    If you dont have access to Windows update:

    Download the latest software from your motherboards website (mine being Asus)
    Put the software onto a usb stick or something
    Transfer it to your PC with Windows 7
    Extract the files and instal the driver via Device manager

    That worked for me and then I used Win Update to get the latest Realtek driver, again just to keep it current.