1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HL2 sound delay

Discussion in 'PC Games' started by 1pudding1, 21 May 2006.

  1. 1pudding1

    Hitman

    Joined: 25 Jul 2003

    Posts: 964

    Location: Cornwall/Bristol

    Hi,

    Ive just started to play HL2 again and get the game finished. But it seems Ive somehow now got a really annoying sound delay between what happens on the screen and the actual playback of the sound. Sooo annoying firing the gun then a second later the bullet sound is heard. Anyone come across this before and know a solution? All other games seem fine :/ Ive got a Nforce2 and have just updated the drivers.
     
  2. 1pudding1

    Hitman

    Joined: 25 Jul 2003

    Posts: 964

    Location: Cornwall/Bristol

    No-one had this problem before or got any suggestions?
     
  3. copycatuk

    Hitman

    Joined: 7 Jun 2004

    Posts: 677

    Location: moon

    verify the cache files and delete the clientregistryblob file in the steam folder
    may fix the problem
     
  4. iGiDK

    Hitman

    Joined: 3 Mar 2006

    Posts: 984

    Location: Falkirk, Scotland

    De-frag your HD

    or

    this link may help

    or try playing with AA disabled

    Hopefully that'll sort it for you mate!
     
  5. 1pudding1

    Hitman

    Joined: 25 Jul 2003

    Posts: 964

    Location: Cornwall/Bristol

    How do I verify the cache files?
     
  6. DaveyD

    Man of Honour

    Joined: 19 Jan 2003

    Posts: 12,647

    Location: Warwickshire

    Right click on HL2 => Properties => Local Files => Verify Integrity of Cache Files

    Have a check on the Steam forums and see if there's anyoy with similar issues.
     
  7. 1pudding1

    Hitman

    Joined: 25 Jul 2003

    Posts: 964

    Location: Cornwall/Bristol

    Damn, none of it worked :( Checked the steam forums and there's nothing there. Its only HL2, CS:S seems fine.
     
  8. Toothpick

    Hitman

    Joined: 3 Dec 2003

    Posts: 605

    try adding this to the launch options: -novid -heapsize 512000

    also try setting sounds to medium quality within the game.