1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I think my baby is finaly dead..

Discussion in 'Photography & Video' started by The_blue, 30 Dec 2010.

  1. The_blue

    Mobster

    Joined: 25 Oct 2002

    Posts: 4,186

    Location: Derbyshire

    My old and so far trusty 300D has developed the err99 :(

    The mirror slap/shutter has changed note. It's more of a squelch at the end and errors every go :(

    The qustion is :- RIP or repair? :(
     
  2. Xein

    Wise Guy

    Joined: 15 Oct 2010

    Posts: 1,394

    I would say RIP :(
     
  3. mrk

    Man of Honour

    Joined: 18 Oct 2002

    Posts: 87,377

    Location: South Coast

    Repair would be more than what it costs to buy 2nd hand, it's not your new tripod counter-weight!
     
  4. The_blue

    Mobster

    Joined: 25 Oct 2002

    Posts: 4,186

    Location: Derbyshire

    What to get now though? I see a 2nd hand 30D is about 220-240 on the bay. The other option is a 450D at about 250.

    Pros and cons please :)
     
  5. Derek W

    Capodecina

    Joined: 1 Oct 2008

    Posts: 11,704

    Location: Glebe Park

  6. mrk

    Man of Honour

    Joined: 18 Oct 2002

    Posts: 87,377

    Location: South Coast

    Depends, what do you need from an imaging tool, buffer speed? Image quality? Handling dynamics?
     
  7. The_blue

    Mobster

    Joined: 25 Oct 2002

    Posts: 4,186

    Location: Derbyshire

    Would like faster buffer and write speeds than the 300D. It's a crawl after the 4 shot buffer :(

    Quality was fine on the 300 and i like the size in hand but also don't mind the shrunken bodys of the newer gens.


    I've got the battery on charge at the moment. I've lost the 2 spares! Only orded 2 new ones this morning :(
     
  8. mrk

    Man of Honour

    Joined: 18 Oct 2002

    Posts: 87,377

    Location: South Coast

    Hmm check out the fix posted above first methinks!
     
  9. The_blue

    Mobster

    Joined: 25 Oct 2002

    Posts: 4,186

    Location: Derbyshire

    Will do, i've had 99 on my old kit lens but it now sounds different. Never done that before :(
     
  10. jaket

    Hitman

    Joined: 26 Jun 2009

    Posts: 610

    Location: Uckfield

    Im still on a 400D and its prefect, with the right lens, will do the job!
     
  11. The_blue

    Mobster

    Joined: 25 Oct 2002

    Posts: 4,186

    Location: Derbyshire

  12. 3dcandy

    Mobster

    Joined: 18 Jun 2003

    Posts: 4,370

    Location: Rugeley

    just was looking at this, my 400D has been ERR99'ing for a bit. Turned off the automatic lens cleaning and now it works again...
     
  13. Raikiri

    Capodecina

    Joined: 5 Jul 2005

    Posts: 17,775

    Location: Brighton

    I would get the 30D in your position, decent upgrade too.
     
  14. neil_g

    Capodecina

    Joined: 9 Dec 2007

    Posts: 10,263

    Location: Hants

    sure its not the lens? i had a similar thing with one of our 20D.. ERR99, odd noise, was sure it was the shutter. on further investigation seems like its the aperture iris sticking in the lens.
     
  15. The_blue

    Mobster

    Joined: 25 Oct 2002

    Posts: 4,186

    Location: Derbyshire

    Sounds the same on 4 lenses :(
     
  16. neil_g

    Capodecina

    Joined: 9 Dec 2007

    Posts: 10,263

    Location: Hants

    damn :(
     
  17. sketch145

    Hitman

    Joined: 2 Mar 2009

    Posts: 577

  18. The_blue

    Mobster

    Joined: 25 Oct 2002

    Posts: 4,186

    Location: Derbyshire

    Hi all, I ended up getting a 30D, should be here in the morning :)
     
  19. davidansell

    Hitman

    Joined: 11 Aug 2010

    Posts: 659

    Location: Cambridge

  20. ElDude

    Mobster

    Joined: 8 Apr 2004

    Posts: 2,734

    Location: Wrexham

    I went from a 300 t a 30D. You'll love the upgrade :)