1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Kangarooing and stalling

Discussion in 'Motors' started by joey1211, 22 Sep 2009.

  1. joey1211

    Mobster

    Joined: 28 Dec 2003

    Posts: 3,336

    Location: Aberwristwatch

    My Astra '02 1.6 has started to kangaroo when cruising. Also stalls when coming to a stop at junctions. Does this whether the engine is cold or warmed-up.

    The problem will suddenly stop only to start up again on the next drive.

    What's up? Cheers
     
  2. InvaderGIR

    Capodecina

    Joined: 14 Jul 2005

    Posts: 17,615

    Location: Bristol

    Dirty fuel filter/problem with the flow of fuel ie fuel pump giving up maybe.
     
  3. iaind

    Capodecina

    Joined: 26 Feb 2009

    Posts: 14,814

    Location: Exeter

    As InvG says, check the fuel filter - could also be MAF or air filter
     
  4. joey1211

    Mobster

    Joined: 28 Dec 2003

    Posts: 3,336

    Location: Aberwristwatch

    The engine warning light on the dash has now started to come on sporadically. Took it into the garage across the road, but by then the light had gone off. They told me that the computer would not show any fault if the light was not on.

    Is this true? Surely some data gets recorded in a FIFO type arrangement. I don't want to get a bill for calling the mobile computer out and the damn light wont come on.
     
  5. Leeum

    Wise Guy

    Joined: 19 Sep 2005

    Posts: 1,242

    Idle control valve perhaps? If you've got time, stripping the throttle body down and cleaning any sensors may rule a few things out. :)