1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Keyboards randomly not powered by USB (Z270E)

Discussion in 'General Hardware' started by Dancer, 14 May 2017.

Tags:
  1. Dancer

    Gangster

    Joined: 17 Mar 2003

    Posts: 351

    Location: London

    I upgraded to an Asus Strix Z270E motherboard couple of weeks ago, and just yesterday my keyboards started misbehaving.

    Mostly they will not receive any power (lights not on) when powering on. If I unplug the USB and plug it back in they work fine. At other times the power light on the keyboard will flicker when I push a key, but the key input is not registered.

    I tried updating the bios. Tried changing usb ports. Mouse works fine in same ports evey time.

    I have been using the keyboards for several years and since they are both showing problem at the same time I think the keyboards are fine.

    One Corsair K70 mechanical keyboard and one typing keyboard (Aurora Enermax).

    Any ideas what the problem might be or what I could try?

    Thanks for any suggestions
     
  2. johnsteR

    Associate

    Joined: 19 Jan 2016

    Posts: 7

    You could see what your ErP setting is in the bios and see if it is disabled
     
  3. fastboy

    Wise Guy

    Joined: 29 Oct 2005

    Posts: 1,114

    Location: wakefield

    my kb did something similair when I was plugged into usb3,sometimes kb would do nothing on booting,switched to usb 2 and was fine.
     
  4. The Only Beardy

    Gangster

    Joined: 10 Dec 2012

    Posts: 254

    I had something like this happen with my Keyboard. Turns out it was having my phone too close to my keyboard that caused it to cut out.