1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Micro-stuttering / hitch & Frametime spikes issue

Discussion in 'Graphics Cards' started by Rachmaninoff, 11 Oct 2020.

  1. Rachmaninoff

    Associate

    Joined: 11 Oct 2020

    Posts: 5

    Hi everyone,

    I want to share an issue I have since a long long time ago. This issue has obsessed me. I've tried everything to solve it and, although it got better, is still there torturing me and preventing me from enjoying gaming.

    The issue is some kind of micro-stutter or hitch that freezes the image (not the sound) just a fraction of second but enough time to break the immersion... frametime spikes.

    Let's see, since I've done thousands of tests with different hardware/drivers combinations I'm just exposing current RIG, where the issue still persists but it's the best experience I've been able to achieve. I can say that I've tested almost every from a default clean Windows 10 installation to a custom installation with these specs/settings/configurations:

    - i7 8700 5.1 GHZ Delidded (tested also before delid, with stock setting, manual OC, bios profile OC ...)
    - Trident Z Neo 32 [2x16] GB RAM DDR4 3600 Mhz CL16-16-16-36 1.35v B-DIE (tested also 1 DIMM, 2 DIMMs, swapped, stock, XMP, manual OC, same with 16 [2x8] GB from Corsair Dominator DDR4 4000 Mhz)
    - Asus Maximus X Apex last bios 2402 (tested with bios stock settings, custom settings...)
    - Asus Rog PG278Q 2560x1440 144hz (tested also with Asus Rog PG348q 3440x1400 100hz)
    - 1x GTX 1080 ti ASUS ROG (tested OC, non-OC, tested with another GTX 1080 ti ASUS ROG in SLI, single, swapped)
    - Samsung NMve M.2 970 Pro 512GB (tested in 4 different SSD: samsung, kingston...)
    - PSU BeQuiet 1500W Dark Power 11 (tested OC six 12V rails, non-OC one massive 12V rail)
    - Water cooling Fractal Design s36 Kelvin

    [Note: all configurations have been tested and stressed, no thermal CPU/GPU throlling found]

    - Windows 10 Pro 2004

    * Opera browser installed
    * Ethernet devices disabled
    * Audio devices disabled
    * GPU/Audio default drivers uninstalled with DDU (safe mode)
    * Nvidia Drivers 456.71 installed (tested with 456.55 and olders)

    * Chipset driver installed
    * ACHI driver installed (when tested in SDD)
    * NVM Samsung drivers installed (when tested in NMve M.2)

    * MSI Afterburner installed
    * Steam installed (overlay disabled)
    * GPU-Z installed
    * CPU-Z installed

    * XBox Game Bar disabled
    * Game Mode enabled (tested with it disabled)
    * VRR and GPU scheduled enabled (tested with them disabled)
    * Windows update disabled
    * Windows antivirus disabled (each time I reboot as I haven't been able to disable it forever)
    * Firewall disabled

    * HPET in device manager disabled
    * CMD:
    bcdedit /set useplatformclock no - Reiniciar
    bcdedit /set useplatformtick yes - Reiniciar
    bcdedit /set disabledynamictick yes - Reiniciar

    * All not needed windows 10 features from configuration disabled (privacy...)
    * All not needed windows 10 applications uninstalled (office, spotify...)
    * Several not needed windows 10 services disabled (SysMain, windows update, printers mangement...)

    * Process Lasso and Park Cores installed (cores unparked and games with high priority class and I/O priority, CPU affinity to all cores/threads, Application power profile to Bitsum Highest Performance)
    * Intelligent standby list cleaner installed and current timer resolution set to 0.5)

    * MSI Util v3 installed and set GTX 1080 ti to MSI mode and Interrupt Priority to High
    * Interrupt Affinity Policy Tool (intPolicy_x64) installed and set GTX 1080 ti to Core 4 and USB HUB to core 2 (first core is 0)

    * Latency Monitor installed

    Steps before starting a game:

    NVidia Control Panel:
    GSYNC, Force V-Sync, Prefer maximum performance, preferred refresh rate highest available (however, I've tested a lot of combinations of v-sync nvidia/in-game, fast, adaptative, no-gsync...)

    MSI Afterburner:
    Cap FPS to 100 (or 60, 90, 98, 120, 142... depending on the monitor and the test I want to do. Also tested with NVCP Framelimiter)
    Monitoring/On screen display: CPUx usage, framerate, frametime)
    Power Limit 120%, temp limit 90º and GPU Boost


    Issue:
    It seems that sometimes when the game has to manage something (load a texture, pop up a new item or npc, show an explosion, do a physics calculation...) there's a micro-stuttering/hitch, a spike in frametime.

    In some games, like The Witcher 3 (occasionally when riding fast but always when opening trunks, boxes or loot), with all previous configuration the result is quite good and I see isolated framespikes from time to time. In others, like Batman Arkham Knight (specially driving the car or each time a radio conversation appears during game) or Deus Ex: Manking Divided (specially Prague), there are framespikes.

    If I cap FPS to 60 spikes disappear in games (however, spikes when opening boxes, for example, are still present, engine maybe?). It makes me think that is something binded to game engines (awful ports maybe?) since when FPS is capped to 90 or 100, for example, none of the cores nor the GPU is reaching 100% nor close. I don't know if its something related to latency that, although i've got pretty good results with Latency Monitor, is not perfect and something is stealing CPU cycles causing interruptions that do not allow CPU to mantain 90 or 100 fps when has to do extra stuff (load texture from SSD, do a physics calculation...).

    The situation get worse with Hyperthreading off. Resolution or graphics settings seems to have no impact.

    Sometimes it seems to me like some kind of unsync between monitor Hz, v-sync, game engine, cpu ... I don't know... maybe I am driving myself insane.

    Here you can see several images that shows the behaviour I've described:

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    Latency Monitor reports
    https://ufile.io/f/q97jk

    If you need any specific MSI Afterburner monitoring graph, any kind of extra information or want me to test again something that I've already listed, I will do with pleasure.

    The fact is that I wanted to buy a brand new RTX 3090 but having the same issue also with this card scares me a lot.

    If I cannot find any fix, at least I hope my post helps somebody to improve his performance as I got my best results with these settings.

    Thank you very much in advance.

    My happiness is in your hands.
     
  2. EastCoastHandle

    Wise Guy

    Joined: 8 Jun 2018

    Posts: 2,256

    I'm not sure what the issue is to be honest. From the screen shots it looks very sporadic yet occasional.

    Do you keep the resolution at 1440p?

    How many processes do you have in task manager when you game? As those hiccups look like i/o activity of some kind.

    2 Possibilities come to mind:
    -gamebarpresencewriter.exe in the background only while gaming. You can check task manager by alt tabing out the game.

    -Another stems from windows anti-virus. Where you have to circumvent Control Flow Guard by disabling it.

    However, you can check to see what else is going on by running latencymon while you game and look at the report to see what processes are being used that shouldn't. But that takes knowing what should and shouldn't be running in the background
     
    Last edited: 11 Oct 2020
  3. meerkat_near

    Perma Banned

    Joined: 24 Sep 2020

    Posts: 42

    Location: Behind you!

    It may not be any help but I had a similar issue once where my RAM had downclocked itself to 2133mhz and this caused the same sort of issue.
     
  4. dazzlaa

    Hitman

    Joined: 30 Jan 2017

    Posts: 686

    Location: Lincs

    Windows defender causes this behaviour on a few games for me. It was final fantasy 15 that led me to a path of discovery though as that really did run like poo. After disabling defender it runs super smooth. Again, like you, I did not have a lack of hardware at all and I know you said you have temporarily disabled defender, but give this a try anyway.

    Windows defender > app&browser control > exploit protection- program settings tab
    Add program and use specific file path for the game .exe

    Then, in that window, use the manual override to turn OFF every single option right down to “validate API”. Turn everything off prior to that setting.
    Do that, restart your game AND the launcher (steam, uplay, whatever).

    This worked for me. Hope you have the same luck.
     
  5. The Old School Gamer

    Hitman

    Joined: 22 Feb 2019

    Posts: 925

    Location: The Twilight Zone

    Try messing around with your Virtual Memory.
    Try a fixed size (1.5x) or even try disabling it altogether and testing again.

    BTW Batman: Arkham Knight is a terrible port.
     
  6. Poneros

    Soldato

    Joined: 18 Feb 2015

    Posts: 5,041

    That's just the CPU getting hit when decompressing. There's nothing you can do about it, the games need to be re-written to better utilise fast storage & manage memory better. Which obviously won't happen for many years if ever for DXMD & Batman.
     
  7. EastCoastHandle

    Wise Guy

    Joined: 8 Jun 2018

    Posts: 2,256

    Hmm, not sure if the OP is still around...
     
  8. VincentHanna

    Capodecina

    Joined: 30 Jul 2013

    Posts: 22,036

    Batman Arkham Knight is flawed, it's the game not your system

     
  9. VincentHanna

    Capodecina

    Joined: 30 Jul 2013

    Posts: 22,036

     
  10. MissChief

    Capodecina

    Joined: 17 Jul 2010

    Posts: 18,928

    @VeNT had a similar issue, turned out to be the Windows Wallpaper refreshing every 60 seconds! He disabled that and it was fixed.
     
  11. Rachmaninoff

    Associate

    Joined: 11 Oct 2020

    Posts: 5

    Hi,

    I am still arround... ;)

    First of all, I want to thank you all your replies and tips. I really appreciate.

    Well, I think this is the end, I mean, with all the things I've tested last months (including yours) I am assuming that this is it, there's no more room for improving.

    At this time, The Witcher 3 runs with rarely frametime spikes or micro freezes (not including those provoked by open boxes, loot...)

    I can play Red Dead Redemption 2 for a long time without being able to see any spike, as well as Doom and, more or less, Hitman has same behaviour.

    But games like Batman, Deus Ex, Far Cry 5 (I think this is well known) cannot be optimized, no way, its engine is a sh** and I have to get over it, haven't I?

    I don't really care about Batman&CO but DCS World hurts me the most. Assume that its frametime spikes (almost each time an asset is loaded, a script event is triggered...) cannot be fixed, at lest not by me (only devs I guess) is going to be hard.

    However, all this crazy trip full of frustration and slepless nights made me optimize my RIG to a obsessive point and now I'll be able to enjoy well programmed games (in addition with a 3090 I hope)

    @Poneros: I think this is, more or less, what you were pointing at, am I right?

    By the way, thanks also for the videos @VicentHanna, Digital Foundry channel is solid seems gold to me.
     
  12. Rachmaninoff

    Associate

    Joined: 11 Oct 2020

    Posts: 5

    In any case, if any of you can run some of these games capped at 90 or 100fps and take a look at the frametime, looking for spikes, it would be very interesting for me. Once I have assumed my last post conclusion, if I see somebody playing Batman or DCS World at 97fps with a solid frametime no medicine will help me ... :_)
     
  13. ualla

    Associate

    Joined: 13 May 2009

    Posts: 24

    Probably not helpful for you unfrotunately, but I had microstutters in certain games (AC Odyssey was doing my head in) and finally discovered that the culprit was the new version of Xbox one controller. I was connecting via BT and with haptic feedback activated.

    Apparently windows was waiting to sync the haptic feedback with the BT signal and therefore caused the microstutters. I deactivated haptic feedback and no more microstutters. I now use an Xbox controller with the wireless adapter instead (only for console style games and when driving).
     
  14. VeNT

    Capodecina

    Joined: 9 Jan 2003

    Posts: 20,674

    Location: Cornwall

    Have you tried disabling your wallpaper switching?
    Or if you have something cycling your Windows colour scheme.
     
  15. Poneros

    Soldato

    Joined: 18 Feb 2015

    Posts: 5,041

    Yup. It's sad when it happens, for me it's Assassin's Creed Odyssey that bothers me the most with this issue. The most severe case was Fallen Order, that one has BAD stutters no matter what.
     
  16. Condemn

    Associate

    Joined: 24 Sep 2020

    Posts: 14

    That's interesting. I've recently upgraded to an i9-9900k with mild OC and a 3080. Ended up doing a playthrough of Deus Ex: Mankind Divided with everything on ultra (apart from msaa), as it's an awesome game imo and wanted to play it with all settings on when it was released. However, I was suffering from micro-stuttering throughout, no matter what I did to try and correct it, so put it down to it being an old game that wasn't well optimised.

    I've then started playing Fallen Order on epic setting and it's as smooth as butter, was really, really surprised on how smooth it is compared to DXMD, is probably one of the smoothest games I've played recently (coming from a 1080) I put it down to it being a newer game with it being optimised better etc. Not sure how I can prove it's so smooth, but in 4 hours of playing I only noticed 4 or 5 times where it slowed down noticeably to load in new assets. I have however spent a fair bit of time when doing the DXMD playthrough to try and reduce as much latency as possible, so not sure if that's made FO smoother for me.

    I do have the same issues on AC:O though, hoping Ragnarok performs a lot better!
     
  17. Rachmaninoff

    Associate

    Joined: 11 Oct 2020

    Posts: 5

    Hi again (sadly...)

    this is some kind of monty python sketch I guess...

    I assumed and accepted that frametime spikes (micro hitches) in some games were impossible to get rid of since they were related to engine but, in the other hand, I achieved superb frametime performance in games like The Witcher 3, Watch Dogs 2, RDR2, Hitman... with not a single spike, thanks to all configuration steps listed in my first post.

    So... I bought a RTX 3090 (Zotac 3090 Trinity) and now I have frametime spikes each few seconds (assets loading) in ALL GAMES, (including those that were performing awesome like TW3, RDR2 and so on.

    I've tried anything (from a simple driver installation through DDU in the system restoration backup I did when performing superb, to several clean installations re-doing all previous steps).

    This is very frustrating, even more than before because I don't know what I am supposed to do since all possible tests were already done during my "first" issue.
     
  18. adrichardson81

    Hitman

    Joined: 6 Dec 2007

    Posts: 948

    Location: Cambridge

    Have you tried a clean windows install with a fresh profile? Try a barebones install with evrtyhthing at stock and only install a known problem game. So Windows and essential drivers only - nothing else.
     
  19. Rachmaninoff

    Associate

    Joined: 11 Oct 2020

    Posts: 5

    Hi @adrichardson81 , thanks for your reply.

    Yes, "several clean installations" meant "clean windows installations" and in all scenarios the only game installed is The Witcher 3 because of is easy for me to make it stutter as I walk/run and engine loads assets.

    What's is "barebones install"? Some kind of special windows version for barebones?