1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MK4 Astra SXi Misfiring?

Discussion in 'Motors' started by blackster, 23 Jan 2006.

  1. blackster

    Hitman

    Joined: 19 Oct 2003

    Posts: 556

    Location: At My Desk

    Hi everyone, I have a 2002 model Mk4 Astra SXI (1.6i)

    I have a slight problem with it, since I had it serviced last year it's been misfiring every since, but it's got worse over the last month of so.

    It seems to feel like I'm running out of petrol type of misfire, it does it in all gears just when I hover on the gas pedal, and last week I was in the 3rd lane of the motorway when the emissions light just came on, but It had been doing the "jerking" as I call it before the light come on, the light stayed on for 2 days then went off, and then come back on again two days later then off again the same day.

    I'm only assuming it's either down to the spark plugs or fuel filter or there's water in the fuel or something.

    But since I have no idea about cars, I just wondered if anyone knew what it might be or had this happen to them.

    I'm going to take it in Vauxhall next week, but I wanted a rough idea on what the cause might be.

    Cheers

    Pete
     
  2. daveski

    Mobster

    Joined: 15 Apr 2004

    Posts: 2,668

    Location: Nottingham

  3. blackster

    Hitman

    Joined: 19 Oct 2003

    Posts: 556

    Location: At My Desk



    Cheers matey, just posted on there now :)