1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help re: permissions

Discussion in 'Linux & Open Source' started by Clark Nova, 7 Feb 2006.

  1. Clark Nova

    Mobster

    Joined: 3 Apr 2003

    Posts: 3,938

    Location: InterZone

    I'm trying to install Opera on my computer but am running into a problem. I go to the console and navigate to the folder with the installation files in and type:

    ./install.sh

    It asks me if I want to proceed with the installation but then tells me I do not have write access to the folder /etc.

    Please try to spare me any jargon, I'm really new to Linux so if you could make the answer as "dumbed down" as possible it will really help me. I want to get into Linux but am finding installations a bit daunting at the moment. I am using Ubuntu 5.10 for x64 if that helps at all :)
     
  2. Dunky

    Gangster

    Joined: 16 May 2005

    Posts: 380

    Location: Glasgow

    Go to the directory where install.sh is and type: sudo sh install.sh and when it asks for a password type your password (the one you use to login).

    The reason is that root has control of nearly all folders apart from your home directory (i.e ~/ or /home/<username>) so you must install as root to put files in directories such as /usr or /etc . To run the program once installed, you will NOT have to be root (i.e type sudo before the command) since you are just reading data in the 'root owned' directories and any personal settings will be saved to your home directory.
     
  3. Clark Nova

    Mobster

    Joined: 3 Apr 2003

    Posts: 3,938

    Location: InterZone

    Thanks very much Dunky, it's installed now as far as I can see but I can't find any shortcuts to launch the program with. This is what happened when I installed Opera:

    Files will be installed as follows:
    -----------------------------------------------------------
    Wrapper Script : /usr/bin
    Binaries : /usr/lib/opera/8.51-20051114.6
    Plugins : /usr/lib/opera/plugins
    Shared files : /usr/share/opera
    Documentation : /usr/share/doc/opera
    -----------------------------------------------------------
    Is this correct [ y,n,c | yes,no,cancel ] ?
    y

    System wide configuration files:
    /etc/opera6rc
    /etc/opera6rc.fixed
    would be ignored if installed with the prefix "/usr".
    Do you want to install them in /etc [ y,n | yes,no ] ?
    y



    Any suggestions? Thanks again for your help :)

    **edited for a typo**
     
    Last edited: 8 Feb 2006
  4. whitecrook

    Sgarrista

    Joined: 22 Aug 2005

    Posts: 8,360

    Location: Clydebank

    type opera
     
  5. Clark Nova

    Mobster

    Joined: 3 Apr 2003

    Posts: 3,938

    Location: InterZone

    Sorry, I'm not up to speed with this still :(

    Which folder do I need to be in when I type it? I've searched through loads of folders but I can't seem to find anything that will launch the program.

    Thanks :)
     
  6. Dunky

    Gangster

    Joined: 16 May 2005

    Posts: 380

    Location: Glasgow

    Open up a terminal window (Accessories > Terminal) and just type: opera (I think). It doesn't matter what folder you are in. This is because the installer puts a sym link (bit like a shortcut) in /usr/bin and any command you type, if it's not found in the current directory then it will check /usr/bin so see if it's there. Most programs will put a shortcut in /usr/bin to allow you to run the program from anywhere
     
  7. Clark Nova

    Mobster

    Joined: 3 Apr 2003

    Posts: 3,938

    Location: InterZone

    Still doesn't seem to be working Dunky :(

    This is what I get when I follow your instructions:

    cd bin
    simon@Desktop:/usr/bin$ opera
    ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
    /usr/lib/opera/8.51-20051114.6/opera: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory
    simon@Desktop:/usr/bin$



    I don't know have a clue what much of that means but I'm guessing it's not installed correctly. Can you help any further? It's greatly appreciated, I'm not a big fan of Firefox and I use Opera from Windows so if I can get it working it will make it so much easier for me to switch :)
     
  8. Mr Potatohead

    Gangster

    Joined: 22 Nov 2003

    Posts: 313

    Location: Aberdeen

    I would wager that
    Code:
    sudo apt-get install libqt3-mt
    would solve at least some of your problems. ;)

    Edit: you can type that in anywhere, you don't need to be in any specific directory.
     
  9. Clark Nova

    Mobster

    Joined: 3 Apr 2003

    Posts: 3,938

    Location: InterZone

    Thanks very much, it's certainly done something:


    simon@Desktop:/usr/bin$ sudo apt-get install libqt3-mt
    Password:
    Reading package lists... Done
    Building dependency tree... Done
    Suggested packages:
    libqt3-mt-psql libqt3-mt-mysql libqt3-mt-odbc
    The following NEW packages will be installed:
    libqt3-mt
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 3605kB of archives.
    After unpacking 11.6MB of additional disk space will be used.
    Get:1 http://gb.archive.ubuntu.com breezy/main libqt3-mt 3:3.3.4-8ubuntu5 [3605kB]
    Fetched 3605kB in 29s (122kB/s)

    Preconfiguring packages ...
    Selecting previously deselected package libqt3-mt.
    (Reading database ... 59729 files and directories currently installed.)
    Unpacking libqt3-mt (from .../libqt3-mt_3%3a3.3.4-8ubuntu5_amd64.deb) ...
    Setting up libqt3-mt (3.3.4-8ubuntu5) ...

    simon@Desktop:/usr/bin$ opera
    ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
    /usr/lib/opera/8.51-20051114.6/opera: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory
    simon@Desktop:/usr/bin$ sudo apt-get install libqt3-mt


    But as you can see it is still not working when I type "opera" in usr/bin. What else do I need to do now? Thanks to all for your help with this :)
     
  10. Mr Potatohead

    Gangster

    Joined: 22 Nov 2003

    Posts: 313

    Location: Aberdeen

    Well, that didn't work, but i can see a solution that should

    http://www.opera.com/download/
    has a platform selection drop-down box - select ubuntu and press download.

    Open a terminal (and if neccessary, navigate to the directory you saved the .deb of opera to) and type
    Code:
    sudo dpkg -i (name of the download)
    Edit: hopefully this will replace the opera files currently on your computer. If the installer you used originally can uninstall, do this first.
     
    Last edited: 8 Feb 2006
  11. Clark Nova

    Mobster

    Joined: 3 Apr 2003

    Posts: 3,938

    Location: InterZone

    Thanks Mr Potatohead, I think that would work but it says it doesn't support the architecture I am using, ie it's only for i386 and not for AMD64 systems. I think I might have to uninstall this version of Ubuntu and install the 32-bit version instead because there are so many things that I can't get installed easily such as Flash, Opera and a few other things which escape me now.

    Thanks again, I'm not going to give up yet. I'll come back to this thread in the morning after I've downloaded the 32-bit ISO and try again. :)
     
  12. Mr Potatohead

    Gangster

    Joined: 22 Nov 2003

    Posts: 313

    Location: Aberdeen

    Ahhh, crap, why must I assume everyone uses x86. Sorry :(
     
  13. leezer3

    Mobster

    Joined: 18 Jan 2006

    Posts: 2,930

    Location: Norwich

  14. Vonhelmet

    Caporegime

    Joined: 28 Jun 2005

    Posts: 48,107

    Location: On the hoods

    You're missing a Java virtual machine. You need to install that. This should do it:

    sudo apt-get install sun-j2re1.5

    Failing that, try apt-cache search j2re and see what you can find.
     
  15. Clark Nova

    Mobster

    Joined: 3 Apr 2003

    Posts: 3,938

    Location: InterZone

    Well, I sorted it out quite easily in the end. I reinstalled Linux as the i386 version of Ubuntu 5.10. Then I ran the Automatix script and it gave me the option to install Opera and the script just did it for me. So now I am pretty much down to using Ubuntu only, just going back into Windows to play games and the such but I'm looking at installing Wine and seeing if I can get them running ok under that this weekend :cool:

    Thanks everyone :)
     
  16. FirebarUK

    Soldato

    Joined: 9 Dec 2004

    Posts: 5,604

    Location: Dorset

    To be honest if your really into your games you'll have to keep Windows.
    Wine wont fair too well (from experience), but Cedega isnt so bad (based on Wine but with lots of tweaks) - you have to pay a subscription for this though. Dont necessarily expect games to run as fast as they do in Windows.
     
    Last edited: 15 Feb 2006