1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Competitor rules

    Please remember that any mention of competitors, hinting at competitors or offering to provide details of competitors will result in an account suspension. The full rules can be found under the 'Terms and Rules' link in the bottom right corner of your screen. Just don't mention competitors in any way, shape or form and you'll be OK.

    Dismiss Notice

normal for 980ti?

Discussion in 'Graphics Cards' started by morta, 13 Aug 2015.

  1. morta

    Gangster

    Joined: 11 Apr 2015

    Posts: 273

    iv had a inno3d hybrid black 980ti and im not happy with how its performing. iv noticed that im not getting good fps in witcher 3.. i would of thought i should be able to max this game out at 60fps ultra on 1080p at least with no drops at all..but this is not the case.. i tested 4k firstly and on ultra i bearly get 17fps when out in the open. on 1440 im not getting past 30 on ultra....on the other hand it runs borderlands prequal at 4k with everything on max apart from physix witch is on high. why am i getting poor performance in witcher 3? is this normal for the card? confused
     
  2. Noxia

    Sgarrista

    Joined: 30 Dec 2010

    Posts: 8,670

    Location: Wiltshire

    Does it have an option about hair works or something. Disable that and try. If I recall it crippled most cards but you should see a massive improvement with it off.
    It may have been as much as 50% performance hit at higher resolutions if I recall.
     
    Last edited: 13 Aug 2015
  3. morta

    Gangster

    Joined: 11 Apr 2015

    Posts: 273

    k i no somthing is wrong now because yesterday i was playing borderlands prequal on 4k and it was smooth as butter..its a stuttery mess now...and even with hari works of at 1440p im only getting 40fps...is there a setting in nvidia control panel or somthing that could be doing this...it was not like this yesterday for sure
     
  4. razorpakk

    Wise Guy

    Joined: 2 Feb 2014

    Posts: 1,374

    Location: London

    Well it seems like you just turn everything on ultra and think it'll just work, even the top card available can't do everything. What's the rest of your pc? At what resolution are you playing? 1080p, 1440p, 4k, I'm confused!
     
  5. Superpatsy

    Hitman

    Joined: 21 Jan 2014

    Posts: 975

    I have everything maxed including Hairworks in The Witcher 3 and get between 40-50fps. Disabling that gets me a solid 60fps at 1440p

    Hairworks just cripples it.
     
  6. Lokken86

    Mobster

    Joined: 8 Mar 2010

    Posts: 4,924

    Location: Aberdeenshire

    Have you tried setting everything to default in the control panel or using other drivers or just reinstalling drivers.
     
  7. morta

    Gangster

    Joined: 11 Apr 2015

    Posts: 273

    not sure what was going on but it must of been a driver problem..since i updated geforce experince..everythings running how it should. borderlands prequal is smooth again at 4 k.. and witcher 3 is running properly again. hope it stays that way.
     
  8. morta

    Gangster

    Joined: 11 Apr 2015

    Posts: 273

    this. but i never used the driver remover tool ..i just used geforce experince to express install updated driver over the preivous one..and its working fine now.
     
  9. Lokken86

    Mobster

    Joined: 8 Mar 2010

    Posts: 4,924

    Location: Aberdeenshire

    No probs good to know its sorted :)
     
  10. riskyfrisky

    Gangster

    Joined: 23 Mar 2012

    Posts: 444

    Location: SY13

    Yesterday I had a GeForce Experience update appear bottom right of screen saying 'new optimal game settings have been applied' or something like that.

    Anyway, I tried to launch Skyrim shortly after and it refused to launch because it had changed the resolution to something ridiculous with DSR for my 1080p TV. I had to go in and change it back.

    Perhaps you had something similar OP?
     
  11. andicole0

    Soldato

    Joined: 12 Sep 2005

    Posts: 6,341

    Location: Robertsbridge

    New Geforce experience with new game settings plus the new Nvidia drivers has given me a massive uplift in fps in W3.

    W3 doesn't like Hairworks, I just use it on Geralt. I also find turning Power Management to max in Nvidia control panel helps. It's worth looking at your SSAO/HBAO setting in W3, Nvidia usually wants to set this to HBAO but I find it has a massive FPS hit so I use SSAO.

    Andi.
     
  12. r0cky

    Hitman

    Joined: 18 Sep 2007

    Posts: 524

    Location: London, England

    Using the latest Nvidia drivers and GeForce Experience settings I get around 50fps, sometimes a little lower, other times 60fps in 1440p.

    This is with Nvidia hairworks set to all.
     
  13. Glanza

    Capodecina

    Joined: 13 Mar 2007

    Posts: 10,779

    Location: South Yorkshire

    Witcher 3 with most settings maxxed and hairworks on got me 45-60fps @ 1440p.