1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Poor performance since upgrade

Discussion in 'General Hardware' started by twoodster, 5 Mar 2010.

  1. twoodster

    Hitman

    Joined: 17 Apr 2006

    Posts: 983

    Hi

    I recently upgraded my computer with the following:

    I already have 4 gig of OcUK PC2-6400 800MHz DDR2 and a Powercolor 4870 1 gig graphics card. I'm running Vista 64 bit. Anyway I mainly upgraded for Bad Company 2 but I can't run it in DX10 with anti-aliasing because the performance is pretty poor. Crysis barely runs any better either.

    Any ideas what could be up? How do you check if a CPU is getting enough power etc? Thanks
     
  2. siumatfung

    Mobster

    Joined: 5 Mar 2009

    Posts: 4,781

    Location: North East

    tbh its your gfx card you should have upgraded :D but erm try running win 7 and erm overclocking the CPU mebbes
     
  3. Vision

    Gangster

    Joined: 10 Dec 2009

    Posts: 497

    Might be the gpu as above
     
  4. King Arthur

    Hitman

    Joined: 19 May 2005

    Posts: 856

    The GPU is your problem, not the CPU, now-a-days CPU's play less of a [part in game performance, while they do help, you main playability comes from the GPU.

    While the parts you have chosen are very good i'd go get your self a 5770 or better GPU

    Phil
     
  5. twoodster

    Hitman

    Joined: 17 Apr 2006

    Posts: 983

    Bugger, I didnt think it was THAT bad a card still! Can't afford to spend another 200 quid right now!