1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Richard Burns Rally Demo @ 1fps

Discussion in 'PC Games' started by pinkacidbootson, 7 Jul 2006.

  1. pinkacidbootson

    Mobster

    Joined: 9 Mar 2006

    Posts: 4,001

    Location: Rhone-Alpes, France

    Ive downloaded and installed the RBR demo, but when i play it, no matter what the sound/graphics settings are it only runs at about 1 frame per second! :confused:
    It does this throughout the demo, even on the menus and loading screens. Does anyone know what the problem is? I have a 7900GT with Forceware 91.31
     
  2. Indy500

    Capodecina

    Joined: 7 Mar 2005

    Posts: 17,509

    Try newer drivers?
     
  3. pinkacidbootson

    Mobster

    Joined: 9 Mar 2006

    Posts: 4,001

    Location: Rhone-Alpes, France

    All my drivers are up to date.
     
  4. Indy500

    Capodecina

    Joined: 7 Mar 2005

    Posts: 17,509

    Theres a 1.02 patch for the retail game, I'm not sure if this can also be applied to the demo.
     
  5. Semiskimmed

    Mobster

    Joined: 30 Jun 2006

    Posts: 4,768

    does it happen with any other games? or just this one?
     
  6. pinkacidbootson

    Mobster

    Joined: 9 Mar 2006

    Posts: 4,001

    Location: Rhone-Alpes, France

    Its just this one, everything else plays fine.
     
  7. Semiskimmed

    Mobster

    Joined: 30 Jun 2006

    Posts: 4,768

    maybe you could grab another download instead then as the one youve got may be corrupt or something? the one i got a few days ago plays fine :confused:
     
  8. Xez

    Wise Guy

    Joined: 24 Jun 2005

    Posts: 2,024

    Location: Lincolnshire

    I would try different drivers. Those didnt work very well for me in any game :(