1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roku4K can't play YouTube Music

Discussion in 'Home Cinema & Hi-Fi' started by juno_first, 24 May 2019.

Tags:
  1. juno_first

    Mobster

    Joined: 18 Apr 2003

    Posts: 2,575

    Location: England

    Roku Streaming Stick+ keeps buffering YouTube Music when there's just a thumbnail, but YouTube Music with video is fine & 4K HDR is flawless.

    Video below is me testing with an older RokuHD under the same conditions. To be clear however, the Roku4K struggles under all conditions eg. different router, TV, time of day or even just the Roku4K on the network.

    I mention the YouTube app damaging OLED TV's but that's on another thread. I now use a second screen to play a video then get no damaging logo.

    I'm now in the crazy situation of using the RokuHD on the 4K TV as Roku is only used for music now, so don't have to have the TV on & it be damaged by the app. By using a HDMI audio splitter to amp.
    The Roku4K is now next to the router on a HD TV in another room & still can't play YouTube Music.

     
  2. jpaul

    Capodecina

    Joined: 1 Mar 2010

    Posts: 13,639

    like I said in original thread

    try your roku 4k at a friends house ? Do you have any links for people with similar problems ? - I had not found any, after the original post
     
  3. juno_first

    Mobster

    Joined: 18 Apr 2003

    Posts: 2,575

    Location: England

    Yeah good idea, maybe there's something on my network the 4k stick does not like, even in another room on a different TV / router.
    Using the HD stick in the same place now & its fine & even has no issues with pilfering the audio from the HDMI feed as the 4k stick gave a HDCP error with some videos from YouTube.
     
  4. juno_first

    Mobster

    Joined: 18 Apr 2003

    Posts: 2,575

    Location: England

    Tried the Streaming Stick+ at a mates house last night & while 4K plays flawlessly, YouTube Music (thumbnail only) still buffers & stutters.
    I presume there's a hardware or software fault with the Roku stick then.
    Does anyone else have a Streaming Stick+ with YouTube Premium who could test a thumbnail only song?
     
  5. NoobCannon

    Soldato

    Joined: 13 Jun 2011

    Posts: 5,393

    Do you really pay for youtube premium?

    First person ive ever seen admit to it
     
  6. juno_first

    Mobster

    Joined: 18 Apr 2003

    Posts: 2,575

    Location: England

    Do you really watch TV
     
  7. NoobCannon

    Soldato

    Joined: 13 Jun 2011

    Posts: 5,393

    Nope?
     
  8. juno_first

    Mobster

    Joined: 18 Apr 2003

    Posts: 2,575

    Location: England

    Do you know if you still have to have a TV license?
     
  9. jpaul

    Capodecina

    Joined: 1 Mar 2010

    Posts: 13,639

    Does roku playback fail on any sound quality setting ? I found one small thread on roku community about this.

    they have a high quality 256Kb/s option now, £10p/m is the market going rate, other than introductory offers is ... is their catalogue known to be 'limited' .. so why not ?
     
  10. juno_first

    Mobster

    Joined: 18 Apr 2003

    Posts: 2,575

    Location: England

    I'm a bit confused. I have audio quality set to very high on mobile devices with no issues. The RokuHD plays music with thumbnails ok too.
     
  11. jpaul

    Capodecina

    Joined: 1 Mar 2010

    Posts: 13,639

    Even though YM normal or HQ, works on other devices - is it not working on SS+ exclusively in HQ ? which could indicate bandwidth is somehow implicated in problem.
     
  12. PiKe

    Caporegime

    Joined: 18 Oct 2002

    Posts: 25,147

    Location: Lake District

    Maybe post over on the Roku forums, more likely to get someone else who has/is experiencing the same issue.
     
  13. juno_first

    Mobster

    Joined: 18 Apr 2003

    Posts: 2,575

    Location: England

    Just found a few posts about this on the Roku forums but none have an answer.
    Its not possible change the audio quality on the Roku app but 4K plays fine which I presume requires more data.
     
  14. jpaul

    Capodecina

    Joined: 1 Mar 2010

    Posts: 13,639

    if they only provide the default 128kb/s YM on roku ss+ & rokuhd, that would be short changing you too.

    have you tried setting the roku ss+ to pcm sound ... eg it's not sending a bitstream to your tv's .. and they are causing the problem.
     
  15. juno_first

    Mobster

    Joined: 18 Apr 2003

    Posts: 2,575

    Location: England

    I use a 2nd screen & pilfer the audio stream from the HDMI feed for an amp rather than the app damaging the OLED TV.
    The issue occurs even if just using the TV or from a mates house on his TV.
    Its fortunate I have an older RokuHD to compare & basically rule everything out. The Roku forums have a few posts about YouTube Music buffering but no fix.
     
  16. juno_first

    Mobster

    Joined: 18 Apr 2003

    Posts: 2,575

    Location: England

    Emailed Roku a video showing the fault on 25th May then 6th June the device received a firmware update & now YouTube (thumbnail) Music plays fine :D
    Maybe the fault was fixed in the firmware update anyway but I'm happy.
     
  17. jpaul

    Capodecina

    Joined: 1 Mar 2010

    Posts: 13,639