1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ryzen 7 2700x - Constant stutter/Lag/Dragging despite high FPS?? Help

Discussion in 'General Hardware' started by rmonkey100, 30 May 2018.

  1. rmonkey100

    Gangster

    Joined: 27 Nov 2012

    Posts: 213

    Never had issues before, recently got a 2700x & x470 ASUS Swift-F mobo, upgrading from a x370 & Ryzen 1700.

    Initally everything worked fine then suddenly it just feels like its stuttering/draggin constantly despite having a high FPS, it happens especially in games I'll be constantly over 120fps, but it feels like I'm playing at 30hz, I have tried everything to fix it including a windows reinstall, different settings etc. The first time I can remember it happening was after overclock teting & a unstable overclock failing, but I have my over clocks stable now so don't know why its still doing it?!

    Specs are 2700x 4.25ghz, 32gb 4x8GB 3000mhz Corsair Vengeance RAM, 120hz Acer PRedator ultrawide 1440p, x470 ROG Strix-F, gtx 1080ti

    I've never had issues like this before but its really annoying especially on games it feels like its constantly dragging/low refresh rate despite it been 140fps most of the time.

    Any ideas?
     
    Last edited: 1 Jun 2018
  2. fastboy

    Wise Guy

    Joined: 29 Oct 2005

    Posts: 1,115

    Location: wakefield

    make sure you have superfetch/prefetch disabled in windows,restart pc and see if that helps.
     
  3. Habakkuk

    Wise Guy

    Joined: 7 Feb 2017

    Posts: 1,015

    Not disagreeing, I've seen that recommendation work before - but why would superfetch make a SSD sluggish with 32GB of RAM?
     
  4. fastboy

    Wise Guy

    Joined: 29 Oct 2005

    Posts: 1,115

    Location: wakefield

    no idea..im not that brainy :)
     
  5. Webzta

    Wise Guy

    Joined: 19 Dec 2005

    Posts: 1,160

    I had this with my 2700x, didn't with the 1700. Got so fed up I swapped it out for an intel setup.

    Hopefully a BIOS/Driver update will fix...
     
  6. rmonkey100

    Gangster

    Joined: 27 Nov 2012

    Posts: 213

    That's annoying it's the same with me, 1700 set up on x370 was fine, but 2700x with x470 has these issues, so annoying, hopefully it is a driver issue & gets fixed..
     
  7. EsaT

    Sgarrista

    Joined: 6 Jun 2008

    Posts: 8,865

    Location: Finland

  8. rmonkey100

    Gangster

    Joined: 27 Nov 2012

    Posts: 213