1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SanDisk Ultra II SSD failed. What are my options to try and access data??

Discussion in 'Storage Drives' started by peanutismint, 21 Jun 2019.

  1. peanutismint

    Hitman

    Joined: 5 Sep 2003

    Posts: 745

    Location: Cardiff Geordie

    One of my SSDs that holds my MacOS install on my PC has seemingly failed without warning. It was 4 years old (just over the 3 year warranty, well played SanDisk...).

    It now doesn't appear in Windows on the same machine or even in BIOS, but it does appear in EaseUS backup software (https://imgur.com/a/kEbuYVG). This happened once before a few weeks ago but after power cycling and re-plugging the SATA/power cables it came back to life. This time, no such luck. I should've sensed the impending doom then....

    I've obviously tried different SATA cables, different SATA ports and different power plugs - no luck with any of them.

    I'm not hugely worried about recovering my data as I store all my important documents/media on a different drive (laughably a mechanical HDD that is like 5+ years older than this failed SSD!!) but I would like to try and get access to one or two files I was working on at the time of failure, if possible. Is there anything else I can try to access the drive? I heard somebody talk about 'power cycling' it without the SATA cable plugged in but this doesn't seem to have worked yet....

    Any ideas how to mount it??
    [​IMG]
     
    Last edited: 21 Jun 2019