1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sound Blaster X-Fi music & Battlefield2

Discussion in 'Sound City' started by ben_j_davis, 23 May 2006.

  1. ben_j_davis

    Wise Guy

    Joined: 26 Sep 2005

    Posts: 1,862

    Location: Tonbridge, Kent

    I recently bought a X-fi music.

    For Battlefield 2 can i set the sound settings to Ultra, or can only cards with X-ram do that?
     
  2. Zebede

    Hitman

    Joined: 21 Aug 2003

    Posts: 800

    Make sure your X-Fi is set to game mode, and you're good to go. :)
     
  3. puppy

    Gangster

    Joined: 20 Nov 2004

    Posts: 485

    Location: London

    Wow

    I was having that problem too - nice solution! I usually have mine in entertainment mode with all the crap turned off so I can listen to music properly :rolleyes: lol
     
  4. M!!cook

    PermaBanned

    Joined: 2 Nov 2005

    Posts: 229

    Location: stockport, cheshire

    me had the same problem! woot solved
     
  5. Shakey_Jake33

    Gangster

    Joined: 22 Jan 2006

    Posts: 263

    Perhaps the biggest flaw with the X-Fi is the need to switch between 'modes', is there no easier way of switching?
     
  6. Capt Doufos

    Mobster

    Joined: 18 Oct 2002

    Posts: 2,602

    Location: Nr Colchester, Essex

    I have a problem, when I switch to game mode the centre channel becomes very faint, and I can't hear people on Mic's. It's fine on entertainment mode.
     
  7. malccy

    Wise Guy

    Joined: 25 Mar 2005

    Posts: 1,830

    Seems to be a problem with the 1.3 bf2 patch and x-fi cards. Played fine once and then would'nt start - checked the creative site with many people having the same problem. In the end had to delete profile and re-install but not have sound set to ultra and x-fi setting.

    From what gather their should be a new x-fi update in next few weeks.