1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to enable Internet Sharing

Discussion in 'Networks & Internet Connectivity' started by Nieldo, 28 Feb 2006.

  1. Nieldo

    Wise Guy

    Joined: 28 Dec 2005

    Posts: 1,992

    Location: Manchester, UK

    hey, I have a Desktop (dirctly connected to the internet) and a laptop (Wireless networked to the desktop).

    Before today everything was working fine, I was able access the internet on the laptop thru the desktop, but today I was messing around with some things since it just stopped working for some reason, I disabled internet sharing on the host and then tryed to enable it agian but it give me this error:

    "An error occured while Internet Connection Sharing was being enabled.
    The specific service does not exist as an installed service."

    I also tried the Connection Wizard and that was failing also.

    I also checked out the Event log and it said this:

    Error
    Source - NetBT
    Description - Initialization failed because the driver device could not be created.


    Any ideas?
     
  2. sja360

    Mobster

    Joined: 28 Jul 2003

    Posts: 3,940

    Location: Dundee

    ICS/ICF Service in control panel -> administrative tools -> services is probably disabled or set to manual, try start the service then try again with checking the internet connection.
     
  3. Nieldo

    Wise Guy

    Joined: 28 Dec 2005

    Posts: 1,992

    Location: Manchester, UK

    I cant find that in the list

    Nothing like Internet connection shairing or ICS in there.
     
  4. Rednut05

    Banned

    Joined: 1 Aug 2005

    Posts: 909

    Basicly go run, type 'services.msc' without the ''''s and then it will load up a list of all the services that load on your computer boot.

    Down the bottom there should be 'Windows Firewall/Internet Connection Sharing (ICS)'. Make sure it is started and if you right click on it. Make sure it says 'Startup type: Automatic'

    Try that?
     
  5. Nieldo

    Wise Guy

    Joined: 28 Dec 2005

    Posts: 1,992

    Location: Manchester, UK

    I dont have Windwos Firewall/Internet COnnection Sharing (ICS) on the list.

    Maybe its because Im running an old version of windows? not SP2
     
  6. sja360

    Mobster

    Joined: 28 Jul 2003

    Posts: 3,940

    Location: Dundee

    old version? as in SP1? or you before that even?
     
  7. Nieldo

    Wise Guy

    Joined: 28 Dec 2005

    Posts: 1,992

    Location: Manchester, UK

    Right updated to windows xp SP2 and all the rest of it, still not fixed the problem.

    I cant see Windwos Firewall/Internet COnnection Sharing (ICS) in the services list.
     
  8. Nieldo

    Wise Guy

    Joined: 28 Dec 2005

    Posts: 1,992

    Location: Manchester, UK

    Found a fix for this problem! Finaly...

    Heres a link to a site with some files, if you have the problem just look on the list (and check the file name because theres a version for xp and 2k). It basicly adds a little key to the registery which tells the service to start up with windows, problem solved! Internet connection sharing up and running :)

    Thanks to those who tryed to help all the same

    http://www.howtonetworking.com/casestudy/error1060.htm