1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Usb 2.0 Not detected??? with xp sp2

Discussion in 'Windows & Other Software' started by harris1986, 5 Feb 2006.

  1. harris1986

    Mobster

    Joined: 4 Aug 2005

    Posts: 2,684

    Hey there guys now i have never really been fussed with usb 2.0 until i bought a external hard drive. I plugged everything in fine powered my computer on and up popped a "this device can perform faster when plugged into a usb 2.0 port" (or something like that), now after checking my device manager it indeed reported than no enhanced usb ports were installed :confused: , so i went back to my motherboard cd to install the drivers as i thought i may have forgotten about it after a re-formatt, but when trying to install the 2.0 drivers it aborts the installation saying that i have windows xp sp2 installed so therefore i don't need to install them. so i'm at a loss here as i have no way of installing the drivers?
     
  2. Rebel=UK=

    Wise Guy

    Joined: 25 Sep 2003

    Posts: 2,345

    Location: South Shields

    This happend to me , i think you needed to install your motherboard drivers before SP2.
     
  3. M0KUJ1N

    PermaBanned

    Joined: 17 Mar 2004

    Posts: 1,486

    Location: Edinburgh

    as of SP1, Windows XP has had generic USB2 drivers built-in.

    This might sound a bit risky but, go into Device Manager, and uninstall all the devices under "USB Serial Bus Controllers". Then reinstall them by scanning for hardware changes in the Action menu.

    Before you use this brute-force method, chack to see if any of your USB controllers have question marks of exclamation marks. If they do, only do the above to that device. If you do have to do a complete rescan of your USB devices, its probably wise to be using a ps2 mouse and keyboard while doing so!
     
  4. harris1986

    Mobster

    Joined: 4 Aug 2005

    Posts: 2,684

    hmmm mite give this a shot, Rebel could be right in saying i need to install usb 2.0 before sp2, i was thinking of uninstalling sp2 but i get a whole host of programmes that mite not work properly so decided against it, i have a new dfi board coming early this week so mite just do a complete re-formatt and install usb 2.0 before sp2.
     
  5. tonys

    Hitman

    Joined: 18 Oct 2002

    Posts: 733

    have you checked that the usb2 controller is enabled in the bios?
     
  6. harris1986

    Mobster

    Joined: 4 Aug 2005

    Posts: 2,684

    this could be a factor, i haven't tonys how embarrasing :( hmm i'l give it a look, i'm going to kick myself if it is only this
     
  7. harris1986

    Mobster

    Joined: 4 Aug 2005

    Posts: 2,684

    just checked and usb 2.0 is enabled in my bios, so i have saved myself embarasment however it still won't work :(
     
  8. harris1986

    Mobster

    Joined: 4 Aug 2005

    Posts: 2,684

    problem solved, went into my device manager and chose to re-install usb drivers that way, sure enough picked my usb 2.0 up straight away :)
     
  9. Bellboy

    Gangster

    Joined: 28 Jan 2005

    Posts: 347

    Idd its a common bug with sp2, doesn't come properly installed so you have to do it yourself.
     
  10. james.miller

    Capodecina

    Joined: 17 Aug 2003

    Posts: 18,655

    Location: Woburn Sand Dunes

    yeah it is. I was just going to suggest going thru the task manager to do it, but i see you've already tried it and it worked.

    so thats cool lol
     
  11. bledd

    Don

    Joined: 21 Oct 2002

    Posts: 46,689

    Location: Parts Unknown

    also, for other people. not all usb cables are usb 2 compatable!