1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Weird experience !

Discussion in 'Sound City' started by R B Customs, 3 Aug 2006.

  1. R B Customs

    Mobster

    Joined: 22 Sep 2005

    Posts: 3,266

    Location: Manchester

    After being a happy owner of my Zen sleek a while, btu not using it as much, i decided to get it out and play some music in my garage
    pluggerd it into the mains and soemthign WEIRD happened

    the screen started to flicker, then i had a very strange feelign in y hands ! it appeared that the whole unit was some how charged with electric !
    when you rubbied it it kinda felt like it was vibrating... JUST like running your hand onver a TV screen.

    its been returned now ( 10 days left on waranty f-t-w ) and replaced with a Vision M

    anyone had anything like this happen to them before ?? / an explanation to what has happened? they couldnt believe it in the sjhop untill the lassy nearly dropped it when it started doign its tricks !
     
  2. Dr.EM

    Mobster

    Joined: 15 Jun 2006

    Posts: 3,903

    Location: Swindon

    It would seem you were recieving a mild electric shock :eek:

    The fault was probably originally in the adapter, but after that had failed and allowed excessive voltage to the unit it would have fried (didn't it smell/smoke at all?). Your probably lucky it was only a mild shock, sounds like it could have been quite nasty though it's difficult to tell exactly what has happened (it could be a far less serrious static build up by your description, but I don't know how with a TFT/LCD screen. Since you say vibrating it does suggest AC mains though).
     
  3. R B Customs

    Mobster

    Joined: 22 Sep 2005

    Posts: 3,266

    Location: Manchester

    was pl;ugged into the mains.
    just really weird !

    i think it was an electric shock i was getting but as i said. it felt EXACTLY like rubbing your hand across a TV screen, you get that kinda bumpy, vibrating feeling.

    it had just been sitting dormant for months and as soon as i dwecide to crank er up. that happened ! lol
    the screen wqas flickerign so that may mean there was some kind of charge going through it !
    i thought it could be quite dangerous tbh