1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Competitor rules

    Please remember that any mention of competitors, hinting at competitors or offering to provide details of competitors will result in an account suspension. The full rules can be found under the 'Terms and Rules' link in the bottom right corner of your screen. Just don't mention competitors in any way, shape or form and you'll be OK.

    Dismiss Notice

Which el cheapo card

Discussion in 'Graphics Cards' started by riddlermarc, 31 May 2006.

  1. riddlermarc

    Man of Honour

    Joined: 15 Nov 2005

    Posts: 2,124

    Location: Basingstoke, UK

    Currently using a GF2 MX 400 64MB (yes, seriously) in my desktop, I've installed Vista Beta 2 (MSDN Universal susbscription) and the GF2 strangely isn't up to the job ;)

    So I'm looking at something as cheap as possible that's DX9-compliant and has 128MB+ ram.. any suggestions? I don't really play any intensive games so that's not too much of a worry..
     
  2. Raikiri

    Capodecina

    Joined: 5 Jul 2005

    Posts: 17,781

    Location: Brighton

  3. senorstealth

    PermaBanned

    Joined: 16 May 2006

    Posts: 276

    Location: down the pub

    Would recommend a 6600gt, not the best gaming card in the world but capable, will run most games, and vista (from experience).

    I just sold mine for £47, so you can pick them up cheap
     
  4. Azza

    Caporegime

    Joined: 6 Dec 2005

    Posts: 35,824

    Location: Birmingham

    i had one of those cards in my old PC. (its going strong at the moment even though its like 5 years old)

    its an alright card seen as it could play HL-2, UT2004, Civ4, CS:S, on low - medium graphics stiing (in UT2004, low in the rest).

    Try a get a 6600GT, there fiarly cheap, and should be fine with Vista.
     
  5. senorstealth

    PermaBanned

    Joined: 16 May 2006

    Posts: 276

    Location: down the pub

    Does run fine with vista, i had dual boot xp pro and vista April CTP running fine for 2 months (before i screwed up the bootloader by reinstalling xp :( )