1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Who owns a Mondeo ST220 / ST TDCI?

Discussion in 'Motors' started by Howard, 8 Apr 2012.

  1. tummelv

    Wise Guy

    Joined: 19 Jan 2011

    Posts: 1,737

    Location: Inverness, Scotland

    ( ͡° ͜ʖ ͡°)
     
  2. Philz0r

    Wise Guy

    Joined: 3 Apr 2011

    Posts: 1,867

    Location: York

    Not yet, don't have the keys to pull it out without causing a mess. Had a play with the Ariel and seems fine. Started working again last night but dead again thismorning.
     
  3. Dav4

    Mobster

    Joined: 20 Apr 2014

    Posts: 2,556

    Location: Home

    Anyone ever had a knocking on full lock from the steering? Also getting a slight whining noise from steering when first moving off in the cold. Could it be cv joints or power steering/ steering rack?
     
  4. James Harris

    Associate

    Joined: 12 Feb 2018

    Posts: 1

    Evenin all!
    I've had a misfire on my ST220 for a while, and have just changed the plugs and leads, but when I pieced it all back together the battery isn't holding a charge. It's a fairly recent battery and it was fine before I started the plugs and leads. I've checked all connections and earths, but can't figure out what's causing it!

    I'm going to change thecoil pack in the morning as the misfire is still there, but know I'll need to jump it.

    What I need to know is, is there an earth strap I could have damaged when taking the inlet manifold off that I can't see easily?

    What are the odds of a battery just dying like that? I could do without paying for a new battery right now!
     
  5. Philz0r

    Wise Guy

    Joined: 3 Apr 2011

    Posts: 1,867

    Location: York

    Hi guys, while doing my spark plugs on the st220, i knocked one of the vacuum lines out of the inlet manifold,. I have the one that goes to the purge valve, no idea where the hose is for the other one.
    [​IMG]
    Can someone check on theirs please. Thanks

    https://imgur.com/a/qGWMQOu

    The blue hose i put on for refrence.


    Google image
    https://goo.gl/images/E7aGdN
     
  6. Philz0r

    Wise Guy

    Joined: 3 Apr 2011

    Posts: 1,867

    Location: York

  7. Dav4

    Mobster

    Joined: 20 Apr 2014

    Posts: 2,556

    Location: Home

    Anybody’s Sony 6 cd changer ever given up on them when they owned there ST220? Mine just says Cd error or something any easy way to get it out because apparently I have to buy 4 keys at £5 just to remove it which i cant be bothered waiting a week to get delivered. Any better things to replace it with or shall I just pay £50 for a used replacement Sony off eBay?
     
  8. Iamzod

    Mobster

    Joined: 7 Dec 2002

    Posts: 3,591

    Location: UK

    If you ditch the sony you'll need to replace the entire centre console as the sony is an odd fitment, it goes in at an angle, any aftermarket stereos won't sit flush as they will stick out half an inch at the bottom.
     
  9. Howard

    Capodecina

    Joined: 12 Jul 2007

    Posts: 16,164

    Location: South East

    Aftermarket single-DIN units fit fine.
     
  10. Dav4

    Mobster

    Joined: 20 Apr 2014

    Posts: 2,556

    Location: Home

    Think I’ll get another Sony then should be able to get a used one off eBay for around £40.
    Do I really need to waste £5 on these key things to get it out or will a screwdriver and some force get it out? I’ve heard it’s awkward even with the 4 keys because of the way they are designed
     
  11. vanpeebles

    Sgarrista

    Joined: 22 Aug 2004

    Posts: 7,603

    Hey you! Yes you! Update your wrong plates thread, we are still waiting!!! ;)
     
  12. Dav4

    Mobster

    Joined: 20 Apr 2014

    Posts: 2,556

    Location: Home

    Bought the 4 keys slid my Sony 6 cd changer out fine but can’t seem to get one of the cables out the back of the CD player to completely remove it. The one on the passenger side removed fine but the big one on the drivers side of the CD player that has loads of coloured cables running into it won’t come out no matter how hard I try I can’t see any clips or anything to get it out so I can swap the CD player over :confused: any help ? Thanks