1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Competitor rules

    Please remember that any mention of competitors, hinting at competitors or offering to provide details of competitors will result in an account suspension. The full rules can be found under the 'Terms and Rules' link in the bottom right corner of your screen. Just don't mention competitors in any way, shape or form and you'll be OK.

    Dismiss Notice

X1900XT & Refresh rates annoyance

Discussion in 'Graphics Cards' started by gazozborne, 26 Feb 2006.

  1. gazozborne

    Gangster

    Joined: 31 Oct 2005

    Posts: 247

    Location: South Yorkshire

    Strange one this, few days ago i had a 6800 AGP in my system thats been @ 60hz all the time - now since i got the XT my refresh rates need to be at 75hz for the screen to be even readable.

    Also everytime i switch a game off & go back to desktop the rate's reset itself back down to 70hz meaning i have to keep changing it back in ATI CC all the time. In CC it's set to tell games to use the same hz as the desktop but it just keeps budging!

    Anyone else had this problem or know how to fix it?
     
  2. smids

    Soldato

    Joined: 18 Dec 2004

    Posts: 6,660

    Location: London/Kent

    You sure it's not a driver conflict with the old nV drivers? I set mine to run at 75Hz and same for games and it never alters.
     
  3. gazozborne

    Gangster

    Joined: 31 Oct 2005

    Posts: 247

    Location: South Yorkshire

    Is there anyway of checking if i still have any Nvidia stuff on?

    Did the drivercleaner pro > restart > ati drivers when i installed it.

    also i just seen a load of "nvdmcpl" stuff in the registry - worth deleting?
     
  4. smids

    Soldato

    Joined: 18 Dec 2004

    Posts: 6,660

    Location: London/Kent

    Hmmm.... I would go and do a driver cleaner again.

    Did you uninstall nV drivers from Add/Remove programs > restart into safe mode > DC Pro 1.4 all nV > restart > install ATi? as that is the exact method to follow.

    Not sure if it's worth deleting unless you know for sure that it is safe to do so - you don't want to kill windows for this little annoyance.
     
  5. gazozborne

    Gangster

    Joined: 31 Oct 2005

    Posts: 247

    Location: South Yorkshire

    Bugger, i didnt do it that way.

    Didnt realise i had to go into safe mode to do the driver cleaner either, il give it a whirl now & find out, cheers!
     
  6. gazozborne

    Gangster

    Joined: 31 Oct 2005

    Posts: 247

    Location: South Yorkshire

    Still got the same problem, went into safe mode & driver cleaned.

    just tried homeworld 2 demo and come out of it - went back down to 70hz & blurry again :-\
     
  7. harris1986

    Mobster

    Joined: 4 Aug 2005

    Posts: 2,684

    hmm although you shouldn't have to have you tried using a programme such as Re-Force?
     
  8. Coolasmoo

    Mobster

    Joined: 18 Oct 2002

    Posts: 4,409

    Location: Mars

    Just to double check your set up right in CCC

    Display Manager > Refresh Rate = 75 (or whatever you use)

    Display Options > 3D Refresh Rate Overide = Same As Desktop
     
  9. gazozborne

    Gangster

    Joined: 31 Oct 2005

    Posts: 247

    Location: South Yorkshire

    Yeah its setup exactly like that - even if i set the rate overide to 75hz it always goes back down to 70hz out of a game.

    Also i just noticed in display settings it only shows 60hz/70hz & not 75hz (whereas with the 6800 it showed 60/70/72). Its not because it doesnt show it in there is it ?
     
  10. gazozborne

    Gangster

    Joined: 31 Oct 2005

    Posts: 247

    Location: South Yorkshire

    Brilliant, thats fixed it!

    Got a Phillips 20" WS coming in a few days aswell, if its still not fixed il do a reformat just to make sure aswell.

    cheers!