1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Competitor rules

    Please remember that any mention of competitors, hinting at competitors or offering to provide details of competitors will result in an account suspension. The full rules can be found under the 'Terms and Rules' link in the bottom right corner of your screen. Just don't mention competitors in any way, shape or form and you'll be OK.

    Dismiss Notice

XFX 4870 512mb Bios wanted (bad flash killer)

Discussion in 'Graphics Cards' started by zenbandit, 13 Sep 2009.

  1. zenbandit

    Associate

    Joined: 12 Sep 2009

    Posts: 3

    Hi all,

    I tried flashing my card with the asus top bios. All done properly through DOS with a USB stick. However card wouldn't post after the flash.

    I didn't take a backup before the flash (lesson learned) and have tried flashing with various differn't bios's for the 4870 from techpowerup (they dont have an xfx 512) and the best I could get was the saphire bios which would cause the power error message to display saying I hadn't connected one of the power connectors (I had).
    I have spend ages trawling net for a bios but no luck so if anybody can help i would be really grateful.

    Thanks for your help guys.

    Matt
     
  2. rjk

    Caporegime

    Joined: 8 Aug 2007

    Posts: 25,313

    and this is why flashing cards is a bad idea

    best i can suggest is emailling XFX
     
  3. Phatzy

    Wise Guy

    Joined: 21 Apr 2008

    Posts: 1,436

    Location: Manchester

  4. zenbandit

    Associate

    Joined: 12 Sep 2009

    Posts: 3

    Yup flashing is bad. learn from my example and if you must flash at least take a backup. What kind of idiot wouldn't take a backup of his bios before flashing it.

    I have had a look over at mvktech but no xfx 4870 bios. Maybe I will post a request over there to see if anyone has one. I will also upon a support ticket with xfx.

    Thanks guys.
     
  5. philip j fry

    Gangster

    Joined: 30 Jan 2009

    Posts: 379

    Location: East Sussex

    The sapphire bios should work have you tried using ATIWinflash. had this with my 4870 512mb 1st time flash through DOS did'nt work so put in my old 1900xt aswell found the 4870 and flashed again using ATIWinflash worked like a charm
     
    Last edited: 13 Sep 2009
  6. zenbandit

    Associate

    Joined: 12 Sep 2009

    Posts: 3

    Thanks Philip J Fry,

    I had a quick look at winflashing this morning but it doesn't seem to like xp64, I then tried using it through RBE but that couldn't find any ati cards!

    I see you are on 64os too, how did you manage it?

    I will have another try when I get back from work and see what I can do.

    I have heard back from xfx who said they should be able to get me a bios in a day or two.

    Thanks